aboutsummaryrefslogtreecommitdiff
path: root/third_party/abseil-cpp/absl/utility/CMakeLists.txt
diff options
context:
space:
mode:
authorHarish Mahendrakar <harish.mahendrakar@ittiam.com>2020-10-27 17:21:06 -0700
committerHarish Mahendrakar <harish.mahendrakar@ittiam.com>2020-10-28 20:50:30 +0000
commitbb55342cbca1f67335f46ee07cdc1f30e4c3b140 (patch)
tree35d73359fd09cc16d1fbb857909581bad75b765e /third_party/abseil-cpp/absl/utility/CMakeLists.txt
parent3e1889fd3ec2121f051cded7fa3aaa946b442a6d (diff)
downloadwebrtc-bb55342cbca1f67335f46ee07cdc1f30e4c3b140.tar.gz
Import abseil-cpp to third_party
Renamed abseil modules to make them webrtc specific. Restricted visibility of abseil modules to webrtc packages. Bug: 171836454 Test: Builds Change-Id: Icf24c7e3093a77dd9a26e7ec78bd531eb1ad3dec
Diffstat (limited to 'third_party/abseil-cpp/absl/utility/CMakeLists.txt')
-rw-r--r--third_party/abseil-cpp/absl/utility/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/third_party/abseil-cpp/absl/utility/CMakeLists.txt b/third_party/abseil-cpp/absl/utility/CMakeLists.txt
new file mode 100644
index 0000000000..e1edd19aa0
--- /dev/null
+++ b/third_party/abseil-cpp/absl/utility/CMakeLists.txt
@@ -0,0 +1,44 @@
+#
+# Copyright 2017 The Abseil Authors.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+absl_cc_library(
+ NAME
+ utility
+ HDRS
+ "utility.h"
+ COPTS
+ ${ABSL_DEFAULT_COPTS}
+ DEPS
+ absl::base_internal
+ absl::config
+ absl::type_traits
+ PUBLIC
+)
+
+absl_cc_test(
+ NAME
+ utility_test
+ SRCS
+ "utility_test.cc"
+ COPTS
+ ${ABSL_TEST_COPTS}
+ DEPS
+ absl::utility
+ absl::core_headers
+ absl::memory
+ absl::strings
+ gmock_main
+)