summaryrefslogtreecommitdiff
path: root/nn/tools/api/types.spec
diff options
context:
space:
mode:
authorLev Proleev <levp@google.com>2020-05-18 15:31:13 +0000
committerAndroid (Google) Code Review <android-gerrit@google.com>2020-05-18 15:31:13 +0000
commit3594be18553db032e3af6dae5c6b9e310eb2f3d8 (patch)
treec4cc08c4c4528d8f7328cd770a665e1278eb9630 /nn/tools/api/types.spec
parent494509a55d3de5627a32dcd69a631b941739ff21 (diff)
parent4a9c8972e3a671e9908d14fd46486ea5dc584a84 (diff)
downloadml-3594be18553db032e3af6dae5c6b9e310eb2f3d8.tar.gz
Merge "Fix null ptr dereference in cpu implementation of operations" into rvc-dev
Diffstat (limited to 'nn/tools/api/types.spec')
-rw-r--r--nn/tools/api/types.spec8
1 files changed, 8 insertions, 0 deletions
diff --git a/nn/tools/api/types.spec b/nn/tools/api/types.spec
index 606af5eaa..bb91b9e43 100644
--- a/nn/tools/api/types.spec
+++ b/nn/tools/api/types.spec
@@ -2521,6 +2521,8 @@
* For a {@link %{OperandTypeLinkPfx}TENSOR_QUANT8_ASYMM} tensor,
* the scale and zeroPoint must be the same as input0.
%/kind
+ * If all dimensions are reduced and keep_dims is false, the output
+ * shape is [1].
%insert-lines AVAIL28
*/
%{DeclareOperation MEAN 31},
@@ -2690,6 +2692,8 @@
* For a {@link %{OperandTypeLinkPfx}TENSOR_QUANT8_ASYMM} tensor,
* the scale and zeroPoint must be the same as input0.
%/kind
+ * If all input dimensions are equal to 1 and are to be squeezed, the
+ * output shape is [1].
%insert-lines AVAIL28
*/
%{DeclareOperation SQUEEZE 34},
@@ -2749,6 +2753,8 @@
* For a {@link %{OperandTypeLinkPfx}TENSOR_QUANT8_ASYMM} tensor,
* the scale and zeroPoint must be the same as input0.
%/kind
+ * If shrink_axis_mask is true for all input dimensions, the output
+ * shape is [1].
%insert-lines AVAIL28
*/
%{DeclareOperation STRIDED_SLICE 35},
@@ -3009,6 +3015,7 @@
*
* Outputs:
* * 0: An (n - 1)-D {@link %{OperandTypeLinkPfx}TENSOR_INT32} tensor.
+ * If input is 1-dimensional, the output shape is [1].
%insert-lines AVAIL29
*/
// There is no underscore in ARG_MAX to avoid name conflict with
@@ -3037,6 +3044,7 @@
*
* Outputs:
* * 0: An (n - 1)-D {@link %{OperandTypeLinkPfx}TENSOR_INT32} tensor.
+ * If input is 1-dimensional, the output shape is [1].
%insert-lines AVAIL29
*/
%{DeclareOperation_1.2 ARGMIN 40}, // See ARGMAX for naming discussion.