summaryrefslogtreecommitdiff
path: root/api/rs_matrix.spec
diff options
context:
space:
mode:
authorJean-Luc Brouillet <jeanluc@google.com>2015-04-03 14:39:53 -0700
committerJean-Luc Brouillet <jeanluc@google.com>2015-04-03 17:15:25 -0700
commit20b27d602a4778ed50a83df2147416a35b7c92be (patch)
tree35184da58f7faf245ebe159434240d73f506202d /api/rs_matrix.spec
parentbfc8ef78572e49b13b8e5335fd0ca00c90f763da (diff)
downloadrs-20b27d602a4778ed50a83df2147416a35b7c92be.tar.gz
Improve the documentation of the RenderScript API.
Only the explanations should be changing. Change-Id: I889b366e3be44f5ac7f44a199e4b9a47353665e2
Diffstat (limited to 'api/rs_matrix.spec')
-rw-r--r--api/rs_matrix.spec10
1 files changed, 4 insertions, 6 deletions
diff --git a/api/rs_matrix.spec b/api/rs_matrix.spec
index d69ad1ab..830dbecd 100644
--- a/api/rs_matrix.spec
+++ b/api/rs_matrix.spec
@@ -15,7 +15,7 @@
#
header:
-summary: Matrix functions
+summary: Matrix Functions
description:
These functions let you manipulate square matrices of rank 2x2, 3x3, and 4x4.
They are particularly useful for graphical transformations and are
@@ -56,7 +56,7 @@ arg: float4* top, "top plane"
arg: float4* bottom, "bottom plane"
arg: float4* near, "near plane"
arg: float4* far, "far plane"
-summary:
+summary: Compute frustum planes
description:
Computes 6 frustum planes from the view projection matrix
inline:
@@ -116,9 +116,9 @@ arg: float4* top, "top plane"
arg: float4* bottom, "bottom plane"
arg: float4* near, "near plane"
arg: float4* far, "far plane"
-summary:
+summary: Checks if a sphere is within the frustum planes
description:
- Checks if a sphere is withing the 6 frustum planes
+ Returns true if the sphere is within the 6 frustum planes.
inline:
float distToCenter = dot(left->xyz, sphere->xyz) + left->w;
if (distToCenter < -sphere->w) {
@@ -171,7 +171,6 @@ description:
test: none
end:
-
function: rsMatrixInverseTranspose
ret: bool
arg: rs_matrix4x4* m, "The matrix to modify."
@@ -182,7 +181,6 @@ description:
test: none
end:
-
function: rsMatrixLoad
t: rs_matrix4x4, rs_matrix3x3, rs_matrix2x2
ret: void