summaryrefslogtreecommitdiff
path: root/api/rs_vector_math.spec
diff options
context:
space:
mode:
authorJean-Luc Brouillet <jeanluc@google.com>2015-04-03 14:39:53 -0700
committerJean-Luc Brouillet <jeanluc@google.com>2015-04-03 17:15:25 -0700
commit20b27d602a4778ed50a83df2147416a35b7c92be (patch)
tree35184da58f7faf245ebe159434240d73f506202d /api/rs_vector_math.spec
parentbfc8ef78572e49b13b8e5335fd0ca00c90f763da (diff)
downloadrs-20b27d602a4778ed50a83df2147416a35b7c92be.tar.gz
Improve the documentation of the RenderScript API.
Only the explanations should be changing. Change-Id: I889b366e3be44f5ac7f44a199e4b9a47353665e2
Diffstat (limited to 'api/rs_vector_math.spec')
-rw-r--r--api/rs_vector_math.spec17
1 files changed, 14 insertions, 3 deletions
diff --git a/api/rs_vector_math.spec b/api/rs_vector_math.spec
index d25bb173..176489a4 100644
--- a/api/rs_vector_math.spec
+++ b/api/rs_vector_math.spec
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2014 The Android Open Source Project
+# Copyright (C) 2015 The Android Open Source Project
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -15,9 +15,20 @@
#
header:
-summary: TODO Add documentation
+summary: Vector Math Functions
description:
- TODO Add documentation
+ These functions interpret the input arguments as representation of vectors in n-dimensional space.
+
+ The precision of the mathematical operations is affected by the pragmas
+# TODO Create an anchor for the section of http://developer.android.com/guide/topics/renderscript/compute.html that details rs_fp_* and link them here.
+ rs_fp_relaxed and rs_fp_full.
+
+ Different precision/speed tradeoffs can be achieved by using three variants
+ of common math functions. Functions with a name starting with<ul>
+ <li>native_ may have custom hardware implementations with weaker precision,</li>
+ <li>half_ may perform internal computations using 16 bit floats, and</li>
+ <li>fast_ are n-dimensional space computations that may use 16 bit floats.
+ </ul>
end:
function: cross