summaryrefslogtreecommitdiff
path: root/rs.spec
diff options
context:
space:
mode:
authorTim Murray <timmurray@google.com>2013-03-18 14:20:14 -0700
committerTim Murray <timmurray@google.com>2013-03-18 14:55:04 -0700
commit29226aed98902c25996e619e0123e410107ee4fa (patch)
tree086a3d6038fc0c587286daf91b2f49be9ffff344 /rs.spec
parent110f181b7966212a36ef18016f9b81c7322d0a2f (diff)
downloadrs-29226aed98902c25996e619e0123e410107ee4fa.tar.gz
Split graphics rs.spec into its own file.
Change-Id: I787ebca11b6cc371d6bddc69a2e8104d6bb420d1
Diffstat (limited to 'rs.spec')
-rw-r--r--rs.spec86
1 files changed, 0 insertions, 86 deletions
diff --git a/rs.spec b/rs.spec
index ad426896..84ccb89a 100644
--- a/rs.spec
+++ b/rs.spec
@@ -418,89 +418,3 @@ ScriptGroupExecute {
-ProgramStoreCreate {
- direct
- param bool colorMaskR
- param bool colorMaskG
- param bool colorMaskB
- param bool colorMaskA
- param bool depthMask
- param bool ditherEnable
- param RsBlendSrcFunc srcFunc
- param RsBlendDstFunc destFunc
- param RsDepthFunc depthFunc
- ret RsProgramStore
- }
-
-ProgramRasterCreate {
- direct
- param bool pointSprite
- param RsCullMode cull
- ret RsProgramRaster
-}
-
-ProgramBindConstants {
- param RsProgram vp
- param uint32_t slot
- param RsAllocation constants
- }
-
-
-ProgramBindTexture {
- param RsProgramFragment pf
- param uint32_t slot
- param RsAllocation a
- }
-
-ProgramBindSampler {
- param RsProgramFragment pf
- param uint32_t slot
- param RsSampler s
- }
-
-ProgramFragmentCreate {
- direct
- param const char * shaderText
- param const char ** textureNames
- param const uint32_t * params
- ret RsProgramFragment
- }
-
-ProgramVertexCreate {
- direct
- param const char * shaderText
- param const char ** textureNames
- param const uint32_t * params
- ret RsProgramVertex
- }
-
-FontCreateFromFile {
- param const char *name
- param float fontSize
- param uint32_t dpi
- ret RsFont
- }
-
-FontCreateFromMemory {
- param const char *name
- param float fontSize
- param uint32_t dpi
- param const void *data
- ret RsFont
- }
-
-MeshCreate {
- param RsAllocation *vtx
- param RsAllocation *idx
- param uint32_t *primType
- ret RsMesh
- }
-
-PathCreate {
- param RsPathPrimitive pp
- param bool isStatic
- param RsAllocation vertex
- param RsAllocation loops
- param float quality
- ret RsPath
- }