summaryrefslogtreecommitdiff
path: root/rs.spec
diff options
context:
space:
mode:
authorChris Wailes <chriswailes@google.com>2014-06-11 12:00:29 -0700
committerChris Wailes <chriswailes@google.com>2014-07-08 11:46:34 -0700
commit4b3c34e6833e39bc89c2128002806b654b8e623d (patch)
treed5e1eeed6ac0e0f9b57488570680b6796ecd7735 /rs.spec
parentcb51798a0379409c0f9927c44bbcdd772ed7ec18 (diff)
downloadrs-4b3c34e6833e39bc89c2128002806b654b8e623d.tar.gz
Adds support for multi-input kernels to Frameworks/RS.
This patch modifies Frameworks/RS in the following ways: * Adjusted the data-layout of the C/C++ version of RsForEachStubParamStruct to accommodate a pointer to an array of input allocations and a pointer to an array of stride sizes for each of these allocatoins. * Adds a new code path for Java code to pass multiple allocations to a RS kernel. * Packs base pointers and step values for multi-input kernels into the new RsForEachStubParamStruct members. Change-Id: I46d2834c37075b2a2407fd8b010546818a4540d1
Diffstat (limited to 'rs.spec')
-rw-r--r--rs.spec10
1 files changed, 9 insertions, 1 deletions
diff --git a/rs.spec b/rs.spec
index 24c06ede..18ece8cd 100644
--- a/rs.spec
+++ b/rs.spec
@@ -295,6 +295,15 @@ ScriptForEach {
param const RsScriptCall * sc
}
+ScriptForEachMulti {
+ param RsScript s
+ param uint32_t slot
+ param RsAllocation * ains
+ param RsAllocation aout
+ param const void * usr
+ param const RsScriptCall * sc
+}
+
ScriptSetVarI {
param RsScript s
param uint32_t slot
@@ -408,4 +417,3 @@ AllocationIoSend {
AllocationIoReceive {
param RsAllocation alloc
}
-