summaryrefslogtreecommitdiff
path: root/rs.spec
diff options
context:
space:
mode:
authorTim Murray <timmurray@google.com>2012-11-16 13:32:24 -0800
committerTim Murray <timmurray@google.com>2012-11-26 12:21:19 -0800
commit7b3e3093f745134345dadf89498ad16e1f9c0e71 (patch)
tree5be7747ebcf24578a06bedf308aa6d8b7c8c78ce /rs.spec
parent0b93e30c8c64fb2f985218adfaceff777f62a42f (diff)
downloadrs-7b3e3093f745134345dadf89498ad16e1f9c0e71.tar.gz
Add support for 2D copies to arbitrary data pointers.
Change-Id: Id92eb508efa9bc85d812b3f41faf98dd74c0c503
Diffstat (limited to 'rs.spec')
-rw-r--r--rs.spec10
1 files changed, 10 insertions, 0 deletions
diff --git a/rs.spec b/rs.spec
index bd0827a9..679b4813 100644
--- a/rs.spec
+++ b/rs.spec
@@ -229,6 +229,16 @@ Allocation1DRead {
param void *data
}
+Allocation2DRead {
+ param RsAllocation va
+ param uint32_t xoff
+ param uint32_t yoff
+ param uint32_t lod
+ param RsAllocationCubemapFace face
+ param uint32_t w
+ param uint32_t h
+ param void *data
+}
AllocationSyncAll {
param RsAllocation va