summaryrefslogtreecommitdiff
path: root/test/putsurface/Makefile.am
diff options
context:
space:
mode:
authorFei Jiang <fei.jiang@intel.com>2010-06-11 10:38:21 +0800
committerFrancis Tharappel <francis.m.tharappel@intel.com>2010-06-15 15:23:52 -0700
commitb0fac498ca4863166252f1268fda83394db54153 (patch)
tree5a16620c688cf15eb5499f615b517ca166be17c2 /test/putsurface/Makefile.am
parentb24acf60aa8e6652897501d47ccbd34f2699ade2 (diff)
downloadlibva-b0fac498ca4863166252f1268fda83394db54153.tar.gz
Replace wind river libva with intel UMG libva.
OpencoreHw will call the same vaPutSurface for texture streaming and overlay display. Divide libva into three libraries: libva, libva-android, libva-tpi libva: general va API libva-android: va API used for android platform libva-tpi: third party interface Reviewed-by:Francis Tharappel Change-Id: Ib8fb9da3b6a463af9b91241392a07fdbd9e1beb9
Diffstat (limited to 'test/putsurface/Makefile.am')
-rw-r--r--test/putsurface/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/test/putsurface/Makefile.am b/test/putsurface/Makefile.am
index 3e5c864..fe18388 100644
--- a/test/putsurface/Makefile.am
+++ b/test/putsurface/Makefile.am
@@ -22,13 +22,15 @@
bin_PROGRAMS = putsurface
-AM_CFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/x11 -DIN_LIBVA
+AM_CFLAGS = -I$(top_srcdir)/va -I$(top_srcdir)/src/x11
-TEST_LIBS = $(top_srcdir)/src/$(libvabackendlib)
+TEST_LIBS = $(top_builddir)/va/$(libvabackendlib) -lpthread
putsurface_LDADD = $(TEST_LIBS)
putsurface_SOURCES = putsurface.c
+EXTRA_DIST = loadsurface.h
+
valgrind: $(bin_PROGRAMS)
for a in $(bin_PROGRAMS); do \