summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRavi Gummadidala <rgummadi@codeaurora.org>2013-03-12 13:45:23 -0700
committerRavi Gummadidala <rgummadi@codeaurora.org>2013-03-12 13:47:49 -0700
commit70267d371f32bd1248d238786657beefbcae1f42 (patch)
tree5c290a7792a7b4034e3813a23c2b6b8d92062e5f /configure.ac
parentef2ae2a4e88e73491f7784a0119af7a029f701b8 (diff)
downloadipacfg-mgr-70267d371f32bd1248d238786657beefbcae1f42.tar.gz
Use sanitized headers in data-ipa-cfg-mgr makefiles
Change-Id: I43450840cb3fc8c288475c8ecb352dd3b4e6eafb
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e77b4f2..8d21dbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,11 @@ AC_SUBST([LIBXML_LIBS])
# Checks for libraries.
+AC_ARG_WITH(sanitized-headers,
+ AS_HELP_STRING([--with-sanitized-headers=DIR],
+ [Specify the location of the sanitized Linux headers]),
+ [CPPFLAGS="$CPPFLAGS -idirafter $withval"])
+
# Checks for header files.
AC_CHECK_HEADERS([fcntl.h netinet/in.h sys/ioctl.h unistd.h])