summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRajavenu Kyatham <rkyatham@codeaurora.org>2016-08-19 17:41:53 +0530
committerGerrit - the friendly Code Review server <code-review@localhost>2016-08-26 02:00:34 -0700
commit038ee099e776e867bfc0f581d261ced2ada75c42 (patch)
tree886742e3647fe8a9e2e458f9d43e26ceafe8738a /configure.ac
parentda3f632cc2086734aa4f28298b6f081866e7d710 (diff)
downloaddisplay-038ee099e776e867bfc0f581d261ced2ada75c42.tar.gz
sdm: Add GCC toolchain compatible makefiles.
CRs-Fixed: 1054762 Change-Id: I370acf2507eaade3d4a96e956ebb5f61f659ceb6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 00000000..6fe7d0ab
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,57 @@
+# -*- Autoconf -*-
+# configure.ac -- Autoconf script for sdm
+#
+
+# Process this file with autoconf to produce a configure script
+
+# Requires autoconf tool later than 2.61
+AC_PREREQ(2.61)
+# Initialize the display package version 1.0.0
+AC_INIT([display],1.0.0)
+# Does not strictly follow GNU Coding standards
+AM_INIT_AUTOMAKE([foreign])
+# Disables auto rebuilding of configure, Makefile.ins
+AM_MAINTAINER_MODE
+# defines some macros variable to be included by source
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_MACRO_DIR([m4])
+AC_SUBST([COMMON_CFLAGS], [-Wall -Werror -Wno-sign-conversion -Wconversion -DDEBUG_CALC_FPS])
+AC_SUBST([AM_CPPFLAGS], [--std=c++11])
+
+AC_ARG_WITH([core_includes],
+ AC_HELP_STRING([--with-core-includes=@<:@dir@:>@],
+ [Specify the location of the core headers]),
+ [core_incdir=$withval],
+ with_core_includes=no)
+
+if test "x$with_core_includes" != "xno"; then
+ CFLAGS="${CFLAGS} -I${core_incdir}"
+fi
+
+AC_ARG_WITH(sanitized-headers,
+ AS_HELP_STRING([--with-sanitized-headers=DIR],
+ [Specify the location of the sanitized Linux headers]),
+ [CPPFLAGS="$CPPFLAGS -idirafter $withval"])
+
+# Checks for programs.
+AC_PROG_CC
+AM_PROG_CC_C_O
+AC_PROG_CXX
+AC_PROG_LIBTOOL
+AC_PROG_AWK
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+
+AC_SUBST([CFLAGS])
+AC_SUBST([CC])
+AC_CONFIG_FILES([ \
+ Makefile \
+ libqservice/Makefile \
+ libqdutils/Makefile \
+ libgralloc/Makefile \
+ sdm/libs/utils/Makefile \
+ sdm/libs/core/Makefile
+ ])
+AC_OUTPUT \ No newline at end of file