summaryrefslogtreecommitdiff
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorDongmei Wang <dongme@codeaurora.org>2014-12-02 18:39:10 -0800
committerGerrit - the friendly Code Review server <code-review@localhost>2014-12-05 15:15:33 -0800
commit836bdc4386232b3a86d062f89f3093845d05cb29 (patch)
treeeca28ce187f928bfdaa7291bd7254d9f2c0cad76 /utils/Makefile.am
parent42c543919b189a758445dc1fd59030e735ad30ec (diff)
downloadgps-836bdc4386232b3a86d062f89f3093845d05cb29.tar.gz
loc-pla: Create Platform Library Abstraction layer
Defined PLA functions to enable gps libraries to call platform-dependent library calls transparantly. Removed fake files and replaced the fake function with defined PLA functions. CRs-fixed: 605817 Change-Id: I677f658001329a10ef9b49bd963631a83fb4c85f
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am13
1 files changed, 4 insertions, 9 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 0e7083e..5e71843 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -6,19 +6,15 @@ AM_CFLAGS = -Wundef \
-fno-short-enums \
-fpic \
-I./ \
- -I../platform_lib_abstractions
+ $(LOCPLA_CFLAGS)
libgps_utils_so_la_h_sources = \
- log_util.h \
msg_q.h \
linked_list.h \
loc_cfg.h \
loc_log.h \
loc_target.h \
- loc_timer.h \
- ../platform_lib_abstractions/platform_lib_includes.h \
- ../platform_lib_abstractions/platform_lib_time.h \
- ../platform_lib_abstractions/platform_lib_macros.h
+ loc_timer.h
libgps_utils_so_la_c_sources = \
linked_list.c \
@@ -26,8 +22,7 @@ libgps_utils_so_la_c_sources = \
loc_cfg.cpp \
loc_log.cpp \
loc_timer.c \
- loc_target.cpp \
- ../platform_lib_abstractions/platform_lib_time.cpp
+ loc_target.cpp
library_includedir = $(pkgincludedir)/utils
@@ -45,7 +40,7 @@ libgps_utils_so_la_LDFLAGS = -lpthread -shared -version-info 1:0:0
libgps_utils_so_la_CPPFLAGS = $(AM_CFLAGS) $(AM_CPPFLAGS)
endif
-libgps_utils_so_la_LIBADD = -lstdc++ -llog
+libgps_utils_so_la_LIBADD = -lstdc++ -llog $(LOCPLA_LIBS)
#Create and Install libraries
lib_LTLIBRARIES = libgps_utils_so.la