summaryrefslogtreecommitdiff
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorKevin Tang <zhikait@codeaurora.org>2019-02-25 13:31:49 -0800
committerGerrit - the friendly Code Review server <code-review@localhost>2019-02-25 16:36:26 -0800
commita928d60188ff466fce61c2c83e381790c4497426 (patch)
tree9b800e82b1e962438ddf3185e47d415d00938301 /utils/Makefile.am
parentd31be6470042dd744a408c207d2b5b7fb7839959 (diff)
downloadgps-a928d60188ff466fce61c2c83e381790c4497426.tar.gz
util to get get symbol from a library
Added dlGetSymFromLib() to provide a utility that dlopen()'s a library, and get the pointer to a symbol name. Change-Id: I770eaef18a61aaa458833b3ca778f44b299585f5 CRs-Fixed: 2404939
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 33afc1b..50e1e9a 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -61,7 +61,7 @@ libgps_utils_la_LDFLAGS = -Wl,-z,defs -lpthread -shared -version-info 1:0:0
libgps_utils_la_CPPFLAGS = $(AM_CFLAGS) $(AM_CPPFLAGS)
endif
-libgps_utils_la_LIBADD = $(CUTILS_LIBS)
+libgps_utils_la_LIBADD = $(CUTILS_LIBS) -ldl
#Create and Install libraries
lib_LTLIBRARIES = libgps_utils.la