summaryrefslogtreecommitdiff
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorKevin Tang <zhikait@codeaurora.org>2019-08-15 15:43:03 -0700
committerKevin Tang <zhikait@codeaurora.org>2019-08-16 11:20:03 -0700
commit32e36b84e103862364a8a037272156b2b3814b6f (patch)
tree3ad8bec2c0f1c1927162525a96d831151836571e /utils/Makefile.am
parente549c9be3b4719dfa2aa5fbc64684c2b358e4213 (diff)
downloadgps-32e36b84e103862364a8a037272156b2b3814b6f.tar.gz
delete of shared LocApiBase::mMsgTask may cause issues
mMsgTask is static, its delete would impact other LocApi objects which don't know it is deleted. Added refcount to manage this shared obj. Change-Id: Iea81039b9cd74081c5230d6bb18ea80c2ee05916 CRs-Fixed: 2505569
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 807916d..9a9c67e 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -29,6 +29,7 @@ libgps_utils_la_h_sources = \
gps_extended.h \
loc_gps.h \
log_util.h \
+ LocSharedLock.h \
LocUnorderedSetMap.h
libgps_utils_la_c_sources = \