summaryrefslogtreecommitdiff
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorhaohuang <haohuang@codeaurora.org>2019-09-16 16:03:09 +0800
committerhaohuang <haohuang@codeaurora.org>2019-11-29 16:28:04 +0800
commitd71529af0f5b103cdbe2679148bd7268cb4713b8 (patch)
tree37acfdeb4fb01c87982bbd8b18f168898bd5f4f2 /utils/Makefile.am
parenta43430218337739c0c1143dc55474d1036d50558 (diff)
downloadgps-d71529af0f5b103cdbe2679148bd7268cb4713b8.tar.gz
Logging buffer implemented by skip list
Use skip list to implement a log buffer, log sentences will be inserted into this buffer once the log print function is called. the buffer will be dumped when GNSS process crash/killed or send SIGUSR1 signal manually. Change-Id: I5e23cdf30c263fa59108070c9dbfd95c49c2e9b6 CRs-Fixed: 2571326
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 9a9c67e..72c7872 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -23,6 +23,7 @@ libgps_utils_la_h_sources = \
LocThread.h \
LocTimer.h \
LocIpc.h \
+ SkipList.h\
loc_misc_utils.h \
loc_nmea.h \
gps_extended_c.h \
@@ -42,6 +43,7 @@ libgps_utils_la_c_sources = \
LocTimer.cpp \
LocThread.cpp \
LocIpc.cpp \
+ LogBuffer.cpp \
MsgTask.cpp \
loc_misc_utils.cpp \
loc_nmea.cpp