summaryrefslogtreecommitdiff
path: root/utils/platform_lib_abstractions/loc_stub/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'utils/platform_lib_abstractions/loc_stub/src/Makefile.am')
-rw-r--r--utils/platform_lib_abstractions/loc_stub/src/Makefile.am40
1 files changed, 0 insertions, 40 deletions
diff --git a/utils/platform_lib_abstractions/loc_stub/src/Makefile.am b/utils/platform_lib_abstractions/loc_stub/src/Makefile.am
deleted file mode 100644
index ba823a2..0000000
--- a/utils/platform_lib_abstractions/loc_stub/src/Makefile.am
+++ /dev/null
@@ -1,40 +0,0 @@
-AM_CFLAGS = \
- -I../include \
- -D__func__=__PRETTY_FUNCTION__ \
- -fno-short-enums
-
-libloc_stub_la_extra_h = \
- ../include/utils/Log.h
-
-libloc_stub_la_c_sources = \
- loc_stub_android_runtime.cpp \
- loc_stub_gettid.cpp \
- loc_stub_property_service.cpp \
- loc_stub_sched_policy.cpp \
- loc_stub_time.cpp
-
-libloc_stub_la_SOURCES = $(libloc_stub_la_c_sources) $(libloc_stub_la_extra_h)
-
-library_include_HEADERS = \
- ../include/loc_stub_android_runtime.h \
- ../include/loc_stub_gettid.h \
- ../include/loc_stub_property_service.h \
- ../include/loc_stub_sched_policy.h \
- ../include/loc_stub_time.h
-
-library_includedir = $(pkgincludedir)
-
-if USE_GLIB
-libloc_stub_la_CFLAGS = -DUSE_GLIB $(AM_CFLAGS) @GLIB_CFLAGS@
-libloc_stub_la_LDFLAGS = -lstdc++ -Wl,-z,defs -lpthread @GLIB_LIBS@ -shared -version-info 1:0:0
-libloc_stub_la_CPPFLAGS = -DUSE_GLIB $(AM_CFLAGS) $(AM_CPPFLAGS) @GLIB_CFLAGS@
-else
-libloc_stub_la_CFLAGS = $(AM_CFLAGS)
-libloc_stub_la_LDFLAGS = -Wl,-z,defs -lpthread -shared -version-info 1:0:0
-libloc_stub_la_CPPFLAGS = $(AM_CFLAGS) $(AM_CPPFLAGS)
-endif
-
-libloc_stub_la_LIBADD = -lstdc++ -ldl -llog
-
-#Create and Install libraries
-lib_LTLIBRARIES = libloc_stub.la