summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDongmei Wang <dongme@codeaurora.org>2014-06-27 14:21:50 -0700
committerGerrit - the friendly Code Review server <code-review@localhost>2014-12-04 23:07:12 -0800
commit91ece00117a01e54e26a863f9a57be2120b55506 (patch)
tree11650f9b2a8dbf7df1d6f4f38eb65ed602f7748e /configure.ac
parent70b94ae2c182efb680199b17c3efa5208e67d08f (diff)
downloadgps-91ece00117a01e54e26a863f9a57be2120b55506.tar.gz
loc-hal:porting from ANDROID_LNX.LA.3.5.1_RB1.04.04.02.048.040
It contains the following changes: - porting from AU_LINUX_ANDROID_LNX.LA.3.5.1_RB1.04.04.02.048.040 - updated package loc-api files according to the merge - rename loc-api to loc-hal - dynamically load liblbs_core.so.1 file for LE platforms - print a warning message when loading the lbs_core library fails CRs-fixed: 605821 Change-Id: I54e1a9c742d1734ffa29e6864901119e0ee600c8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 5aac06e..9b0f6ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,11 +1,11 @@
-# configure.ac -- Autoconf script for gps loc_api
+# configure.ac -- Autoconf script for gps loc_hal
#
# Process this file with autoconf to produce a configure script
# Requires autoconf tool later than 2.61
AC_PREREQ(2.61)
-# Initialize the gps loc_api package version 1.0.0
-AC_INIT([loc-api],1.0.0)
+# Initialize the gps loc-hal package version 1.0.0
+AC_INIT([loc-hal],1.0.0)
# Does not strictly follow GNU Coding standards
AM_INIT_AUTOMAKE([foreign])
# Disables auto rebuilding of configure, Makefile.ins
@@ -29,10 +29,18 @@ AC_PROG_MAKE_SET
PKG_PROG_PKG_CONFIG
# Checks for libraries.
+PKG_CHECK_MODULES([QMI], [qmi])
+AC_SUBST([QMI_CFLAGS])
+AC_SUBST([QMI_LIBS])
+
PKG_CHECK_MODULES([QMIF], [qmi-framework])
AC_SUBST([QMIF_CFLAGS])
AC_SUBST([QMIF_LIBS])
+PKG_CHECK_MODULES([DATA], [data])
+AC_SUBST([DATA_CFLAGS])
+AC_SUBST([DATA_LIBS])
+
AC_ARG_WITH([libhardware_includes],
AC_HELP_STRING([--with-libhardware-includes=@<:@dir@:>@],
[Specify the location of the libhardware headers]),
@@ -77,8 +85,9 @@ AM_CONDITIONAL(USE_GLIB, test "x${with_glib}" = "xyes")
AC_CONFIG_FILES([ \
Makefile \
utils/Makefile \
+ core/Makefile \
loc_api/Makefile \
- loc-api.pc \
+ loc-hal.pc \
])
AC_OUTPUT