summaryrefslogtreecommitdiff
path: root/core/Makefile.am
diff options
context:
space:
mode:
authorKatz Yamada <kyamada@codeaurora.org>2017-03-14 11:13:23 -0700
committerKatz Yamada <kyamada@codeaurora.org>2017-03-21 09:55:08 -0700
commit592b3f557edac9a1e25a8a22306573ee7f530ee9 (patch)
treef099b0f2b494b19751e05efcd73d532a174e3b39 /core/Makefile.am
parent681388fa8dd3f1ff9c8b788ac20e90a16fd5b62d (diff)
downloadgps-592b3f557edac9a1e25a8a22306573ee7f530ee9.tar.gz
SystemStatus - initial release
Add GNSS SystemStatus component to handle debug NMEA messages from mpss. This component handles GNSS debug info sent through debug NMEA and then stores it in its cache and pass it to clients per requests. Also debug NMEA is turned on by default. Change-Id: Ia11a124ff43d27568f544a3a4742dd7a846869fe CRs-Fixed: 1099152
Diffstat (limited to 'core/Makefile.am')
-rw-r--r--core/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/core/Makefile.am b/core/Makefile.am
index b3d833f..6a4f353 100644
--- a/core/Makefile.am
+++ b/core/Makefile.am
@@ -16,14 +16,16 @@ libloc_core_la_h_sources = \
gps_extended_c.h \
gps_extended.h \
loc_core_log.h \
- LocAdapterProxyBase.h
+ LocAdapterProxyBase.h \
+ SystemStatus.h
libloc_core_la_c_sources = \
LocApiBase.cpp \
LocAdapterBase.cpp \
ContextBase.cpp \
LocDualContext.cpp \
- loc_core_log.cpp
+ loc_core_log.cpp \
+ SystemStatus.cpp
library_includedir = $(pkgincludedir)/core