summaryrefslogtreecommitdiff
path: root/utils/configure.ac
diff options
context:
space:
mode:
authorKevin Tang <zhikait@codeaurora.org>2016-09-12 17:20:55 -0700
committerMike Cailean <mcailean@codeaurora.org>2018-01-16 13:35:38 -0800
commit61de97e13003a5dea9917cb6e943ecd8e142b05b (patch)
tree31ddbc97199253187cbee24932f8712e2216f83d /utils/configure.ac
parent438abebca035fe4f956e7e6232a1b98074e4c673 (diff)
downloadgps-61de97e13003a5dea9917cb6e943ecd8e142b05b.tar.gz
LE clean up
separated utils, core, ds and loc-api-v02 from loc-hal into their own independent packages; simplified loc-pla; moved pla to the root of project; removed loc-stub. Change-Id: I373f02f9306646addf55ae90d71c4ba8e3741d09 CRs-Fixed: 2172544
Diffstat (limited to 'utils/configure.ac')
-rw-r--r--utils/configure.ac29
1 files changed, 26 insertions, 3 deletions
diff --git a/utils/configure.ac b/utils/configure.ac
index a7ab9b4..639f8c4 100644
--- a/utils/configure.ac
+++ b/utils/configure.ac
@@ -28,9 +28,32 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
PKG_PROG_PKG_CONFIG
-PKG_CHECK_MODULES([LOCPLA], [loc-pla])
-AC_SUBST([LOCPLA_CFLAGS])
-AC_SUBST([LOCPLA_LIBS])
+# Checks for libraries.
+PKG_CHECK_MODULES([CUTILS], [libcutils])
+AC_SUBST([CUTILS_CFLAGS])
+AC_SUBST([CUTILS_LIBS])
+
+AC_ARG_WITH([core_includes],
+ AC_HELP_STRING([--with-core-includes=@<:@dir@:>@],
+ [Specify the location of the core headers]),
+ [core_incdir=$withval],
+ with_core_includes=no)
+
+if test "x$with_core_includes" != "xno"; then
+ CPPFLAGS="${CPPFLAGS} -I${core_incdir}"
+fi
+
+AC_ARG_WITH([locpla_includes],
+ AC_HELP_STRING([--with-locpla-includes=@<:@dir@:>@],
+ [specify the path to locpla-includes in loc-pla_git.bb]),
+ [locpla_incdir=$withval],
+ with_locpla_includes=no)
+
+if test "x$with_locpla_includes" != "xno"; then
+ AC_SUBST(LOCPLA_CFLAGS, "-I${locpla_incdir}")
+fi
+
+AC_SUBST([CPPFLAGS])
AC_ARG_WITH([glib],
AC_HELP_STRING([--with-glib],