summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasha Smundak <asmundak@google.com>2019-01-09 16:39:54 -0800
committerSasha Smundak <asmundak@google.com>2019-01-09 16:39:54 -0800
commitbfe4700669c7212edf43b7590a02a484227e4373 (patch)
tree5df6659b93df0f3980a91cdbcf064e2970d5d8fc
parent157c0199e36283f18e3dfa9ae2b24e25b5bf2e3a (diff)
downloadBasicSmsReceiver-bfe4700669c7212edf43b7590a02a484227e4373.tar.gz
Convert Android.mk file to Android.bp
See build/soong/README.md for more information. Change-Id: Iae2e66d358cff168893f1fb6bab843919c539968 Fixes: 122333003 Test: treehugger
-rw-r--r--Android.bp10
-rwxr-xr-xAndroid.mk20
-rw-r--r--tests/Android.bp33
-rw-r--r--tests/Android.mk37
4 files changed, 43 insertions, 57 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..ef40b29
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,10 @@
+// Copyright 2007-2011 The Android Open Source Project
+android_app {
+ name: "BasicSmsReceiver",
+ libs: ["telephony-common"],
+ srcs: ["src/**/*.java"],
+ platform_apis: true,
+ optimize: {
+ proguard_flags_files: ["proguard.flags"],
+ },
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100755
index 4463e3f..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 2007-2011 The Android Open Source Project
-
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := optional
-
-LOCAL_JAVA_LIBRARIES := telephony-common
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := BasicSmsReceiver
-
-LOCAL_PRIVATE_PLATFORM_APIS := true
-
-LOCAL_PROGUARD_FLAG_FILES := proguard.flags
-
-include $(BUILD_PACKAGE)
-
-# This finds and builds the test apk as well, so a single make does both.
-include $(call all-makefiles-under,$(LOCAL_PATH))
diff --git a/tests/Android.bp b/tests/Android.bp
new file mode 100644
index 0000000..d5e865a
--- /dev/null
+++ b/tests/Android.bp
@@ -0,0 +1,33 @@
+// Copyright 2011, The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+android_test {
+ name: "BasicSmsReceiverTests",
+
+ libs: [
+ "android.test.runner",
+ "telephony-common",
+ "android.test.base",
+ ],
+ static_libs: ["junit"],
+ // Include all test java files.
+ srcs: ["src/**/*.java"],
+
+ // Notice that we don't have to include the src files of Email because, by
+ // running the tests using an instrumentation targeting Eamil, we
+ // automatically get all of its classes loaded into our environment.
+
+ platform_apis: true,
+ instrumentation_for: "BasicSmsReceiver",
+}
diff --git a/tests/Android.mk b/tests/Android.mk
deleted file mode 100644
index 2d35bb2..0000000
--- a/tests/Android.mk
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2011, The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-# We only want this apk build for tests.
-LOCAL_MODULE_TAGS := tests
-
-LOCAL_JAVA_LIBRARIES := android.test.runner telephony-common android.test.base
-LOCAL_STATIC_JAVA_LIBRARIES := junit
-
-# Include all test java files.
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-# Notice that we don't have to include the src files of Email because, by
-# running the tests using an instrumentation targeting Eamil, we
-# automatically get all of its classes loaded into our environment.
-
-LOCAL_PACKAGE_NAME := BasicSmsReceiverTests
-LOCAL_PRIVATE_PLATFORM_APIS := true
-
-LOCAL_INSTRUMENTATION_FOR := BasicSmsReceiver
-
-include $(BUILD_PACKAGE)
-