summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 16:09:06 +0000
committerAnton Hansson <hansson@google.com>2018-02-23 16:29:24 +0000
commite477616485f138ff6cb8e753f13722f043947bc5 (patch)
treea33ffe4f614e51a25aa7bfcd605103108b3171f0
parent112fa57f2c771de070d67bfd9119f09575d1b2d5 (diff)
downloadBasicSmsReceiver-e477616485f138ff6cb8e753f13722f043947bc5.tar.gz
packages/apps/BasicSmsReceiver: Set LOCAL_SDK_VERSION where possible.
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: I2b3321134f1500438513e9fec104f239cf067b0b
-rwxr-xr-xAndroid.mk3
-rw-r--r--tests/Android.mk1
2 files changed, 2 insertions, 2 deletions
diff --git a/Android.mk b/Android.mk
index 50d2f1c..4463e3f 100755
--- a/Android.mk
+++ b/Android.mk
@@ -10,8 +10,7 @@ LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := BasicSmsReceiver
-# Builds against the public SDK
-#LOCAL_SDK_VERSION := current
+LOCAL_PRIVATE_PLATFORM_APIS := true
LOCAL_PROGUARD_FLAG_FILES := proguard.flags
diff --git a/tests/Android.mk b/tests/Android.mk
index e6eb52d..912b8cf 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -29,6 +29,7 @@ LOCAL_SRC_FILES := $(call all-java-files-under, src)
# automatically get all of its classes loaded into our environment.
LOCAL_PACKAGE_NAME := BasicSmsReceiverTests
+LOCAL_PRIVATE_PLATFORM_APIS := true
LOCAL_INSTRUMENTATION_FOR := BasicSmsReceiver