summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-01-17 14:49:41 +0000
committerPaul Duffin <paulduffin@google.com>2017-01-17 14:49:41 +0000
commitc0446ebc7eb629f4faf598649030deb8ade543ae (patch)
tree5319fbd9fd06159e0b329aae4454e8f6bb96b6c0
parent4175f5e7127817eb956c5b957caedc3ded98fa36 (diff)
downloadBasicSmsReceiver-c0446ebc7eb629f4faf598649030deb8ade543ae.tar.gz
Prepare for removal of legacy-test from default targets
In preparation for removing junit classes from the Android API the legacy-test target will be removed from the TARGET_DEFAULT_JAVA_LIBRARIES. This change adds explicit dependencies on junit and/or legacy-android-test to ensure that modules will compile properly once it is removed. Bug: 30188076 Test: make checkbuild Change-Id: I51a454298c2f03272025a20298df318192becd75
-rw-r--r--tests/Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
index 892a3b8..e6eb52d 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -19,6 +19,7 @@ include $(CLEAR_VARS)
LOCAL_MODULE_TAGS := tests
LOCAL_JAVA_LIBRARIES := android.test.runner telephony-common
+LOCAL_STATIC_JAVA_LIBRARIES := junit legacy-android-test
# Include all test java files.
LOCAL_SRC_FILES := $(call all-java-files-under, src)