summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xAndroid.mk20
-rwxr-xr-xAndroidManifest.xml41
-rwxr-xr-xCleanSpec.mk49
-rwxr-xr-xMODULE_LICENSE_APACHE20
-rwxr-xr-xNOTICE190
-rwxr-xr-xproguard.flags0
-rwxr-xr-xres/drawable-hdpi/stat_notify_sms.pngbin0 -> 2398 bytes
-rwxr-xr-xres/drawable-mdpi/stat_notify_sms.pngbin0 -> 1949 bytes
-rwxr-xr-xres/values/strings.xml21
-rwxr-xr-xsrc/com/android/basicsmsreceiver/BasicSmsReceiverApp.java62
-rwxr-xr-xsrc/com/android/basicsmsreceiver/DialogSmsDisplay.java94
-rwxr-xr-xsrc/com/android/basicsmsreceiver/SmsMessageReceiver.java97
12 files changed, 574 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
new file mode 100755
index 0000000..c0cb798
--- /dev/null
+++ b/Android.mk
@@ -0,0 +1,20 @@
+# Copyright 2007-2011 The Android Open Source Project
+
+LOCAL_PATH:= $(call my-dir)
+include $(CLEAR_VARS)
+
+LOCAL_MODULE_TAGS := optional
+
+LOCAL_SRC_FILES := $(call all-java-files-under, src)
+
+LOCAL_PACKAGE_NAME := BasicSmsReceiver
+
+# Builds against the public SDK
+#LOCAL_SDK_VERSION := current
+
+LOCAL_PROGUARD_FLAG_FILES := proguard.flags
+
+include $(BUILD_PACKAGE)
+
+# This finds and builds the test apk as well, so a single make does both.
+include $(call all-makefiles-under,$(LOCAL_PATH))
diff --git a/AndroidManifest.xml b/AndroidManifest.xml
new file mode 100755
index 0000000..5f1a947
--- /dev/null
+++ b/AndroidManifest.xml
@@ -0,0 +1,41 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!--
+/*
+ * Copyright (C) 2007-2011 The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+-->
+<manifest xmlns:android="http://schemas.android.com/apk/res/android"
+ package="com.android.basicsmsreceiver">
+
+ <original-package android:name="com.android.basicsmsreceiver" />
+
+ <uses-permission android:name="android.permission.RECEIVE_SMS" />
+
+ <application android:name="BasicSmsReceiverApp"
+ android:label="@string/sms_app_name"
+ android:hardwareAccelerated="true">
+
+ <activity android:name=".DialogSmsDisplay"
+ android:theme="@android:style/Theme.Holo.Dialog"
+ android:launchMode="singleTop" />
+
+ <receiver android:name=".SmsMessageReceiver">
+ <intent-filter>
+ <action android:name="android.provider.Telephony.SMS_RECEIVED" />
+ </intent-filter>
+ </receiver>
+
+ </application>
+</manifest>
diff --git a/CleanSpec.mk b/CleanSpec.mk
new file mode 100755
index 0000000..b84e1b6
--- /dev/null
+++ b/CleanSpec.mk
@@ -0,0 +1,49 @@
+# Copyright (C) 2007 The Android Open Source Project
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+# If you don't need to do a full clean build but would like to touch
+# a file or delete some intermediate files, add a clean step to the end
+# of the list. These steps will only be run once, if they haven't been
+# run before.
+#
+# E.g.:
+# $(call add-clean-step, touch -c external/sqlite/sqlite3.h)
+# $(call add-clean-step, rm -rf $(PRODUCT_OUT)/obj/STATIC_LIBRARIES/libz_intermediates)
+#
+# Always use "touch -c" and "rm -f" or "rm -rf" to gracefully deal with
+# files that are missing or have been moved.
+#
+# Use $(PRODUCT_OUT) to get to the "out/target/product/blah/" directory.
+# Use $(OUT_DIR) to refer to the "out" directory.
+#
+# If you need to re-do something that's already mentioned, just copy
+# the command and add it to the bottom of the list. E.g., if a change
+# that you made last week required touching a file and a change you
+# made today requires touching the same file, just copy the old
+# touch step and add it to the end of the list.
+#
+# ************************************************
+# NEWER CLEAN STEPS MUST BE AT THE END OF THE LIST
+# ************************************************
+
+# For example:
+#$(call add-clean-step, rm -rf $(OUT_DIR)/target/common/obj/APPS/AndroidTests_intermediates)
+#$(call add-clean-step, rm -rf $(OUT_DIR)/target/common/obj/JAVA_LIBRARIES/core_intermediates)
+#$(call add-clean-step, find $(OUT_DIR) -type f -name "IGTalkSession*" -print0 | xargs -0 rm -f)
+#$(call add-clean-step, rm -rf $(PRODUCT_OUT)/data/*)
+
+# ************************************************
+# NEWER CLEAN STEPS MUST BE AT THE END OF THE LIST
+# ************************************************
diff --git a/MODULE_LICENSE_APACHE2 b/MODULE_LICENSE_APACHE2
new file mode 100755
index 0000000..e69de29
--- /dev/null
+++ b/MODULE_LICENSE_APACHE2
diff --git a/NOTICE b/NOTICE
new file mode 100755
index 0000000..c5b1efa
--- /dev/null
+++ b/NOTICE
@@ -0,0 +1,190 @@
+
+ Copyright (c) 2005-2008, The Android Open Source Project
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+
+
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+ 6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+ END OF TERMS AND CONDITIONS
+
diff --git a/proguard.flags b/proguard.flags
new file mode 100755
index 0000000..e69de29
--- /dev/null
+++ b/proguard.flags
diff --git a/res/drawable-hdpi/stat_notify_sms.png b/res/drawable-hdpi/stat_notify_sms.png
new file mode 100755
index 0000000..1209c18
--- /dev/null
+++ b/res/drawable-hdpi/stat_notify_sms.png
Binary files differ
diff --git a/res/drawable-mdpi/stat_notify_sms.png b/res/drawable-mdpi/stat_notify_sms.png
new file mode 100755
index 0000000..5d05d50
--- /dev/null
+++ b/res/drawable-mdpi/stat_notify_sms.png
Binary files differ
diff --git a/res/values/strings.xml b/res/values/strings.xml
new file mode 100755
index 0000000..81dfc6d
--- /dev/null
+++ b/res/values/strings.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!-- Copyright (C) 2007 The Android Open Source Project
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+-->
+
+<resources xmlns:xliff="urn:oasis:names:tc:xliff:document:1.2">
+ <string name="sms_app_name">Simple message receiver</string>
+ <string name="sms_message_from_format">Message from %1$s</string>
+ <string name="sms_done_button">Done</string>
+</resources>
diff --git a/src/com/android/basicsmsreceiver/BasicSmsReceiverApp.java b/src/com/android/basicsmsreceiver/BasicSmsReceiverApp.java
new file mode 100755
index 0000000..2db846b
--- /dev/null
+++ b/src/com/android/basicsmsreceiver/BasicSmsReceiverApp.java
@@ -0,0 +1,62 @@
+/*
+ * Copyright (C) 2011 The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+package com.android.basicsmsreceiver;
+
+import android.app.Activity;
+import android.app.Application;
+import android.content.SharedPreferences;
+import android.util.Log;
+
+public class BasicSmsReceiverApp extends Application {
+ public static final String LOG_TAG = "BasicSmsReceiverApp";
+ public static final String SMS_LITE_PREFS_KEY = "sms_lite_prefs";
+ public static final String PREF_KEY_NOTIFICATION_ID = "notification_id";
+
+ static BasicSmsReceiverApp gBasicSmsReceiverApp;
+
+ @Override
+ public void onCreate() {
+ super.onCreate();
+
+ gBasicSmsReceiverApp = this;
+ }
+
+ public static BasicSmsReceiverApp getBasicSmsReceiverApp() {
+ return gBasicSmsReceiverApp;
+ }
+
+ // Each incoming sms gets its own notification. We have to use a new unique notification id
+ // for each one.
+ public int getNextNotificationId() {
+ SharedPreferences prefs = getSharedPreferences(SMS_LITE_PREFS_KEY,
+ Activity.MODE_PRIVATE);
+ int notificationId = prefs.getInt(PREF_KEY_NOTIFICATION_ID, 0);
+ ++notificationId;
+ if (notificationId > 32765) {
+ notificationId = 1; // wrap around before it gets dangerous
+ }
+
+ // Save the updated notificationId in SharedPreferences
+ SharedPreferences.Editor editor = prefs.edit();
+ editor.putInt(PREF_KEY_NOTIFICATION_ID, notificationId);
+ editor.apply();
+
+ Log.d(LOG_TAG, "getNextNotificationId: " + notificationId);
+
+ return notificationId;
+ }
+}
diff --git a/src/com/android/basicsmsreceiver/DialogSmsDisplay.java b/src/com/android/basicsmsreceiver/DialogSmsDisplay.java
new file mode 100755
index 0000000..a6bb19b
--- /dev/null
+++ b/src/com/android/basicsmsreceiver/DialogSmsDisplay.java
@@ -0,0 +1,94 @@
+/*
+ * Copyright (C) 2011 The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+package com.android.basicsmsreceiver;
+
+import java.util.Locale;
+
+import android.app.Activity;
+import android.app.AlertDialog;
+import android.app.Dialog;
+import android.app.NotificationManager;
+import android.content.Context;
+import android.content.DialogInterface;
+import android.content.Intent;
+import android.os.Bundle;
+import android.util.Log;
+import android.view.KeyEvent;
+import android.view.View;
+import android.view.Window;
+
+public class DialogSmsDisplay extends Activity {
+ private static final String LOG_TAG = "SmsReceivedDialog";
+
+ private static final int DIALOG_SHOW_MESSAGE = 1;
+
+ public static final String SMS_FROM_ADDRESS_EXTRA =
+ "com.android.basicsmsreceiver.SMS_FROM_ADDRESS";
+ public static final String SMS_MESSAGE_EXTRA =
+ "com.android.basicsmsreceiver.SMS_MESSAGE";
+ public static final String SMS_NOTIFICATION_ID_EXTRA =
+ "com.android.basicsmsreceiver.NOTIFICATION_ID";
+
+ private String mFromAddress;
+ private String mMessage;
+
+ @Override
+ protected void onCreate(Bundle savedInstanceState) {
+ super.onCreate(savedInstanceState);
+
+ Bundle extras = getIntent().getExtras();
+ mFromAddress = extras.getString(SMS_FROM_ADDRESS_EXTRA);
+ mMessage = extras.getString(SMS_MESSAGE_EXTRA);
+ int notificationId = extras.getInt(SMS_NOTIFICATION_ID_EXTRA);
+
+ Log.i(LOG_TAG, "notificationId: " + notificationId);
+
+ // Dismiss the notification that brought us here.
+ NotificationManager notificationManager =
+ (NotificationManager)getSystemService(Context.NOTIFICATION_SERVICE);
+ notificationManager.cancel(notificationId);
+
+ showDialog(DIALOG_SHOW_MESSAGE);
+ }
+
+ @Override
+ protected Dialog onCreateDialog(int id) {
+ switch (id) {
+ case DIALOG_SHOW_MESSAGE:
+ return new AlertDialog.Builder(this)
+ .setTitle(String.format(getString(R.string.sms_message_from_format),
+ mFromAddress))
+ .setMessage(mMessage)
+ .setCancelable(true)
+ .setOnCancelListener(new AlertDialog.OnCancelListener() {
+ public void onCancel(DialogInterface dialog) {
+ dialog.dismiss();
+ finish();
+ }
+ })
+ .setNeutralButton(R.string.sms_done_button,
+ new DialogInterface.OnClickListener() {
+ public void onClick(DialogInterface dialog, int whichButton) {
+ dialog.dismiss();
+ finish();
+ }
+ })
+ .create();
+ }
+ return null;
+ }
+}
diff --git a/src/com/android/basicsmsreceiver/SmsMessageReceiver.java b/src/com/android/basicsmsreceiver/SmsMessageReceiver.java
new file mode 100755
index 0000000..b3c86c7
--- /dev/null
+++ b/src/com/android/basicsmsreceiver/SmsMessageReceiver.java
@@ -0,0 +1,97 @@
+/*
+ * Copyright (C) 2011 The Android Open Source Project
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+package com.android.basicsmsreceiver;
+
+import android.app.Notification;
+import android.app.NotificationManager;
+import android.app.PendingIntent;
+import android.content.BroadcastReceiver;
+import android.content.Context;
+import android.content.Intent;
+import android.database.Cursor;
+import android.net.Uri;
+import android.os.Bundle;
+import android.provider.ContactsContract;
+import android.telephony.SmsMessage;
+import android.util.Log;
+import android.widget.RemoteViews;
+
+public class SmsMessageReceiver extends BroadcastReceiver {
+ /** Tag string for our debug logs */
+ private static final String LOG_TAG = "SmsMessageReceiver";
+
+ @Override
+ public void onReceive(Context context, Intent intent) {
+ Bundle extras = intent.getExtras();
+ Log.i(LOG_TAG, "onReceive");
+ if (extras == null)
+ return;
+
+ Object[] pdus = (Object[]) extras.get("pdus");
+
+ for (int i = 0; i < pdus.length; i++) {
+ SmsMessage message = SmsMessage.createFromPdu((byte[]) pdus[i]);
+ String fromAddress = message.getOriginatingAddress();
+ String messageBody = message.getMessageBody().toString();
+
+ Log.i(LOG_TAG, "From: " + fromAddress + " message: " + messageBody);
+
+ addNotification(context, fromAddress, messageBody);
+ }
+ }
+
+ private void addNotification(Context context, String fromAddress, String message) {
+ int notificationId = BasicSmsReceiverApp.getBasicSmsReceiverApp().getNextNotificationId();
+
+ Notification.Builder notification = new Notification.Builder(context)
+ .setTicker(message)
+ .setWhen(System.currentTimeMillis())
+ .setContentTitle(fromAddress)
+ .setContentText(message)
+ .setSmallIcon(R.drawable.stat_notify_sms)
+ .setContentIntent(createDisplayMessageIntent(context, fromAddress, message,
+ notificationId));
+
+ Log.i(LOG_TAG, "addNotification notificationId: " + notificationId);
+
+ NotificationManager notificationManager =
+ (NotificationManager)context.getSystemService(Context.NOTIFICATION_SERVICE);
+
+ notificationManager.notify(notificationId, notification.getNotification());
+ }
+
+ private PendingIntent createDisplayMessageIntent(Context context, String fromAddress,
+ String message, int notificationId) {
+ // Trigger the main activity to fire up a dialog that shows the received messages
+ Intent di = new Intent();
+ di.setClass(context, DialogSmsDisplay.class);
+ di.setFlags(Intent.FLAG_ACTIVITY_NEW_TASK | Intent.FLAG_ACTIVITY_SINGLE_TOP |
+ Intent.FLAG_ACTIVITY_CLEAR_TOP);
+ di.putExtra(DialogSmsDisplay.SMS_FROM_ADDRESS_EXTRA, fromAddress);
+ di.putExtra(DialogSmsDisplay.SMS_MESSAGE_EXTRA, message);
+ di.putExtra(DialogSmsDisplay.SMS_NOTIFICATION_ID_EXTRA, notificationId);
+
+ // This line is needed to make this intent compare differently than the other intents
+ // created here for other messages. Without this line, the PendingIntent always gets the
+ // intent of a previous message and notification.
+ di.setType(Integer.toString(notificationId));
+
+ PendingIntent pendingIntent = PendingIntent.getActivity(context, 0, di, 0);
+ return pendingIntent;
+ }
+
+}