aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-03-01 13:21:10 +0000
committerPaul Duffin <paulduffin@google.com>2017-03-01 13:21:10 +0000
commitbb53fd26f3bf4cc82466554718fc7d89dca51bc8 (patch)
treea970e0bd39031683ff2e5767d4fabbef49738643
parent2984ebd99e762dbd4ca1bebbbe1baf2710967cc6 (diff)
downloadBrowser2-bb53fd26f3bf4cc82466554718fc7d89dca51bc8.tar.gz
Prepare for removal of junit and android.test classes from Android API (step 1)android-o-preview-1android-n-mr2-preview-2o-preview
In preparation for removing junit and android.test classes from the Android API this change adds explicit dependencies on junit and/or legacy-android-test to ensure that modules will compile properly once it is removed. Care was taken to ensure that any targets that depended, directly or indirectly, on android-support-test did not also depend on junit or hamcrest as they conflict with the versions embedded within android-support-test. Bug: 30188076 Test: make checkbuild Change-Id: I0cb8c39bdfbefb92db48c30815ee4902d13a3fed
-rw-r--r--Android.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 81513d0..d69ca83 100644
--- a/Android.mk
+++ b/Android.mk
@@ -8,6 +8,8 @@ LOCAL_SDK_VERSION := current
LOCAL_SRC_FILES := \
$(call all-java-files-under, src)
+LOCAL_STATIC_JAVA_LIBRARIES := legacy-android-test junit
+
LOCAL_PACKAGE_NAME := Browser2
include $(BUILD_PACKAGE)