summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoryangbill <yangbill@google.com>2023-11-07 10:32:04 +0800
committeryangbill <yangbill@google.com>2023-11-08 09:16:22 +0800
commitd5d22638e51ae83501f4bbc9a5ee4b9e5641b538 (patch)
tree0d647ae523b660371e3bb075c6d969e4ef3c9074
parentff602fc403cef62035ba1b977c790c9e297d4716 (diff)
downloadCalendar-d5d22638e51ae83501f4bbc9a5ee4b9e5641b538.tar.gz
Convert the Android.mk of CalendarTests to Android.bp
Convert the CalendarTests's Android.mk to Android.bp and fix the missing Calendar apk dependency issue. Bug: 309369509 Test: atest CalendarTests Change-Id: I3d59f7867cf0fc1af6e0d860b7ad6503c61f4230
-rw-r--r--tests/Android.bp36
-rw-r--r--tests/Android.mk23
2 files changed, 36 insertions, 23 deletions
diff --git a/tests/Android.bp b/tests/Android.bp
new file mode 100644
index 00000000..8e84ae7d
--- /dev/null
+++ b/tests/Android.bp
@@ -0,0 +1,36 @@
+// Copyright 2023 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: [
+ "packages_apps_Calendar_license",
+ ],
+}
+
+android_test {
+ name: "CalendarTests",
+ jacoco: {
+ include_filter: ["com.android.calendar.*"],
+ },
+ srcs: ["src/**/*.java"],
+ instrumentation_for: "Calendar",
+ // unbundled
+ static_libs: ["android-common"],
+ sdk_version: "16",
+ // Test needed artifacts
+ data: [
+ ":Calendar",
+ ],
+}
diff --git a/tests/Android.mk b/tests/Android.mk
deleted file mode 100644
index 9a272dfb..00000000
--- a/tests/Android.mk
+++ /dev/null
@@ -1,23 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_JACK_COVERAGE_INCLUDE_FILTER := com.android.calendar.*
-
-# We only want this apk build for tests.
-LOCAL_MODULE_TAGS := tests
-
-# Include all test java files.
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := CalendarTests
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-LOCAL_NOTICE_FILE := $(LOCAL_PATH)/../NOTICE
-
-LOCAL_INSTRUMENTATION_FOR := Calendar
-
-# unbundled
-LOCAL_STATIC_JAVA_LIBRARIES := android-common
-LOCAL_SDK_VERSION := 16
-
-include $(BUILD_PACKAGE)