summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeil Fuller <nfuller@google.com>2019-07-22 12:17:55 -0700
committerandroid-build-merger <android-build-merger@google.com>2019-07-22 12:17:55 -0700
commitf2b635393c18e00ba05c2323ffda654f85292d2c (patch)
treec80cb78b8b1adda84ec51157829b0999480e124e
parent34ca7c66722c94c7b5e41ab8967135c3584aba9c (diff)
parent147e6a9613fab326f3bf0a87df49488a4a79aaa1 (diff)
downloadCalendar-f2b635393c18e00ba05c2323ffda654f85292d2c.tar.gz
Merge "Remove deps on frameworks/opt/datetimepicker"
am: 147e6a9613 Change-Id: I3e07d219a5a8361fa04001c0eee292abebf51135
-rw-r--r--Android.mk8
-rw-r--r--res/color/done_text_color.xml21
-rw-r--r--res/color/done_text_color_dark.xml21
-rw-r--r--res/values/colors.xml5
4 files changed, 49 insertions, 6 deletions
diff --git a/Android.mk b/Android.mk
index e899923e..27886cab 100644
--- a/Android.mk
+++ b/Android.mk
@@ -4,9 +4,8 @@ include $(CLEAR_VARS)
# Include res dir from chips
chips_dir := ../../../frameworks/opt/chips/res
color_picker_dir := ../../../frameworks/opt/colorpicker/res
-datetimepicker_dir := ../../../frameworks/opt/datetimepicker/res
timezonepicker_dir := ../../../frameworks/opt/timezonepicker/res
-res_dirs := $(chips_dir) $(color_picker_dir) $(datetimepicker_dir) $(timezonepicker_dir) res
+res_dirs := $(chips_dir) $(color_picker_dir) $(timezonepicker_dir) res
src_dirs := src
LOCAL_JACK_COVERAGE_INCLUDE_FILTER := com.android.calendar.*
@@ -26,7 +25,6 @@ LOCAL_STATIC_JAVA_LIBRARIES := \
android-common \
libchips \
colorpicker \
- android-opt-datetimepicker \
android-opt-timezonepicker \
androidx.legacy_legacy-support-v4 \
calendar-common
@@ -39,15 +37,13 @@ LOCAL_PACKAGE_NAME := Calendar
LOCAL_COMPATIBILITY_SUITE := general-tests
-LOCAL_PROGUARD_FLAG_FILES := proguard.flags \
- ../../../frameworks/opt/datetimepicker/proguard.flags
+LOCAL_PROGUARD_FLAG_FILES := proguard.flags
LOCAL_PRODUCT_MODULE := true
LOCAL_AAPT_FLAGS := --auto-add-overlay
LOCAL_AAPT_FLAGS += --extra-packages com.android.ex.chips
LOCAL_AAPT_FLAGS += --extra-packages com.android.colorpicker
-LOCAL_AAPT_FLAGS += --extra-packages com.android.datetimepicker
LOCAL_AAPT_FLAGS += --extra-packages com.android.timezonepicker
LOCAL_AAPT_FLAGS += --legacy
diff --git a/res/color/done_text_color.xml b/res/color/done_text_color.xml
new file mode 100644
index 00000000..85d0e9e9
--- /dev/null
+++ b/res/color/done_text_color.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!-- Copyright (C) 2013 The Android Open Source Project
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+-->
+<selector xmlns:android="http://schemas.android.com/apk/res/android">
+
+ <item android:state_enabled="false" android:color="@color/done_text_color_disabled"/>
+ <item android:color="@color/done_text_color_normal"/>
+
+</selector> \ No newline at end of file
diff --git a/res/color/done_text_color_dark.xml b/res/color/done_text_color_dark.xml
new file mode 100644
index 00000000..070baf2f
--- /dev/null
+++ b/res/color/done_text_color_dark.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!-- Copyright (C) 2013 The Android Open Source Project
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+-->
+<selector xmlns:android="http://schemas.android.com/apk/res/android">
+
+ <item android:state_enabled="false" android:color="@color/done_text_color_dark_disabled"/>
+ <item android:color="@color/done_text_color_dark_normal"/>
+
+</selector> \ No newline at end of file
diff --git a/res/values/colors.xml b/res/values/colors.xml
index 2ef7a4bc..988bcc4f 100644
--- a/res/values/colors.xml
+++ b/res/values/colors.xml
@@ -167,4 +167,9 @@
<color name="recurrence_picker_background">#fff2f2f2</color>
<color name="recurrence_bubble_text_normal">#ff737373</color>
+
+ <color name="done_text_color_normal">#000000</color>
+ <color name="done_text_color_disabled">#cccccc</color>
+ <color name="done_text_color_dark_normal">#ffffff</color>
+ <color name="done_text_color_dark_disabled">#888888</color>
</resources>