summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlya Trafimovich <skvadrik@google.com>2021-03-11 12:54:01 +0000
committerUlya Trafimovich <skvadrik@google.com>2021-03-11 13:59:05 +0000
commit1b234fa5b730d931b653c0753b506c6be815c73c (patch)
tree9cde1e8cc804cd3f3886e58b774680bae66ee18c
parentf3707cc57bde343368db4ade7ec6d44fc89fca82 (diff)
downloadCamera2-1b234fa5b730d931b653c0753b506c6be815c73c.tar.gz
Add <uses-library> information.
Camera2 app uses non-optional "org.apache.http.legacy" library. It is necessary to add this information to LOCAL_USES_LIBRARIES to pass manifest_check and generate correct class loader context for dexpreopt. Bug: 132357300 Test: m out/target/common/obj/APPS/Camera2_intermediates/enforce_uses_libraries.status Test: lunch aosp_cf_x86_64_phone-userdebug && m && launch_cvd \ adb wait-for-device && adb root && adb logcat \ | grep -E 'ClassLoaderContext [a-z ]+ mismatch' # no mismatch error messages related to Camera2 Change-Id: I39c1b30a59f172fb865ddde6003f9761a1889c80
-rw-r--r--Android.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index b24a2df57..cebce76f4 100644
--- a/Android.mk
+++ b/Android.mk
@@ -15,6 +15,8 @@ LOCAL_STATIC_JAVA_LIBRARIES += glide
LOCAL_STATIC_JAVA_LIBRARIES += guava
LOCAL_STATIC_JAVA_LIBRARIES += jsr305
+LOCAL_USES_LIBRARIES := org.apache.http.legacy
+
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_SRC_FILES += $(call all-java-files-under, src_pd)
LOCAL_SRC_FILES += $(call all-java-files-under, src_pd_gcam)