summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Chen <ajchen@google.com>2018-04-04 17:35:06 -0700
committerAnthony Chen <ajchen@google.com>2018-04-04 17:35:06 -0700
commit3ea9448f8d88173240440f85a739195c353de9ee (patch)
tree9a15dfec23d8fc0b718fb62f7859a9f254e91b9b
parentdcc4e38d1d67878bb2b4ee99c7cf9d9a387aaef7 (diff)
downloadLocalMediaPlayer-3ea9448f8d88173240440f85a739195c353de9ee.tar.gz
Depend on correct target for the car support library.
The macro that was being depended on before has been deprecated. Instead, applications can just depend on the android-support-car target directly. Also, remove the dependency on car-stream-ui-lib, which was not providing anything. Bug: 77601495 Test: build and deploy LocalMediaPlayer Change-Id: Ie27bdd0713dce09845585d5f94bb6bdb51fd7a0f
-rw-r--r--Android.mk11
1 files changed, 2 insertions, 9 deletions
diff --git a/Android.mk b/Android.mk
index f1bc1df..59973fe 100644
--- a/Android.mk
+++ b/Android.mk
@@ -46,22 +46,15 @@ LOCAL_MODULE_TAGS := optional
LOCAL_PRIVILEGED_MODULE := true
-include packages/apps/Car/libs/car-stream-ui-lib/car-stream-ui-lib.mk
-
LOCAL_STATIC_JAVA_LIBRARIES += \
LocalMediaPlayer-proto
LOCAL_STATIC_ANDROID_LIBRARIES := \
- android-support-v4 \
- $(ANDROID_SUPPORT_DESIGN_TARGETS)
+ android-support-car \
+ android-support-v4
LOCAL_USE_AAPT2 := true
-# Include support-v7-appcompat, if not already included
-ifeq (,$(findstring android-support-v7-appcompat,$(LOCAL_STATIC_ANDROID_LIBRARIES)))
-LOCAL_STATIC_ANDROID_LIBRARIES += android-support-v7-appcompat
-endif
-
LOCAL_PROGUARD_ENABLED := disabled
LOCAL_DEX_PREOPT := false