summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTreeHugger Robot <treehugger-gerrit@google.com>2017-11-21 21:22:22 +0000
committerAndroid (Google) Code Review <android-gerrit@google.com>2017-11-21 21:22:22 +0000
commit1f3c39d639f054af167cc9f22a1397b82ea37c8c (patch)
tree10b158547f021d3f21469245dbddf701035d2316
parent3bf7bee2a2cefe4407f0cce11a17a606044177cc (diff)
parent2c94c3c3aad7e64bb61087c059a857a4e82fac1f (diff)
downloadMessenger-1f3c39d639f054af167cc9f22a1397b82ea37c8c.tar.gz
Merge "Added LOCAL_INSTRUMENT_SOURCE_DIRS to capture code coverage."
-rw-r--r--tests/robotests/Android.mk11
1 files changed, 9 insertions, 2 deletions
diff --git a/tests/robotests/Android.mk b/tests/robotests/Android.mk
index 49245df..d568cd2 100644
--- a/tests/robotests/Android.mk
+++ b/tests/robotests/Android.mk
@@ -8,7 +8,8 @@ LOCAL_SRC_FILES := $(call all-java-files-under, src)
# Include the testing libraries (JUnit4 + Robolectric libs).
LOCAL_STATIC_JAVA_LIBRARIES := \
- truth-prebuilt
+ truth-prebuilt \
+ mockito-robolectric-prebuilt
LOCAL_JAVA_LIBRARIES := \
junit \
@@ -36,4 +37,10 @@ LOCAL_STATIC_JAVA_LIBRARIES := \
LOCAL_TEST_PACKAGE := CarMessengerApp
-include prebuilts/misc/common/robolectric/3.1.1/run_robotests.mk \ No newline at end of file
+LOCAL_ROBOTEST_FILES := $(filter-out %/BaseRobolectricTest.java,\
+ $(call find-files-in-subdirs,$(LOCAL_PATH)/src,*Test.java,.))
+
+LOCAL_INSTRUMENT_SOURCE_DIRS := $(dir $(LOCAL_PATH))../src
+
+#Require Robolectric 3.4.2 since the min-SDK target is 24
+include prebuilts/misc/common/robolectric/3.4.2/run_robotests.mk \ No newline at end of file