summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 16:09:51 +0000
committerAnton Hansson <hansson@google.com>2018-02-22 16:09:51 +0000
commitf0d7e6682215d707578ebce4480d0a9e4109a952 (patch)
tree683922ec26ac6b0616b1d938911cc8c9d3a74707
parentc6afb36e77d24ebbad4a693ab8c5f66d66ea8e41 (diff)
downloadMessenger-f0d7e6682215d707578ebce4480d0a9e4109a952.tar.gz
packages/apps/Car/Messenger: Set LOCAL_SDK_VERSION where possible.android-p-preview-1android-o-mr1-iot-preview-7o-mr1-iot-preview-7
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: I10bb2b07934419023f333b0c9ec9f444aaea8a33
-rw-r--r--Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 9fc5f09..b51c009 100644
--- a/Android.mk
+++ b/Android.mk
@@ -26,6 +26,7 @@ LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
LOCAL_MODULE_TAGS := optional
LOCAL_PACKAGE_NAME := CarMessengerApp
+LOCAL_PRIVATE_PLATFORM_APIS := true
LOCAL_OVERRIDES_PACKAGES := messaging