summaryrefslogtreecommitdiff
path: root/SetupWizard/Android.mk
diff options
context:
space:
mode:
authorAnthony Chen <ajchen@google.com>2017-01-27 11:00:04 -0800
committerAnthony Chen <ajchen@google.com>2017-02-21 14:56:58 -0800
commit2066ca63ba8f0765ee30e1be14552866da35d8ac (patch)
treee0272a1183896ff9c8dabec890adc129dd01d768 /SetupWizard/Android.mk
parent240360dcbcb2ed46c1f4a16615e87ceafd0d6419 (diff)
downloadUserManagement-2066ca63ba8f0765ee30e1be14552866da35d8ac.tar.gz
Bluetooth configuration for SetupWizard.
This bluetooth activity will ask the user to pair a bluetooth device. Upon completion of a successful pairing, the screen will move onto the next action. This means during setup, only a single bluetooth item will be set up. Test: manually tested Bug: 34378933 Change-Id: I4469c274cf0ba063a871b8772d33496a99de4d5b
Diffstat (limited to 'SetupWizard/Android.mk')
-rw-r--r--SetupWizard/Android.mk45
1 files changed, 45 insertions, 0 deletions
diff --git a/SetupWizard/Android.mk b/SetupWizard/Android.mk
new file mode 100644
index 0000000..3a151f2
--- /dev/null
+++ b/SetupWizard/Android.mk
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2017 The Android Open Source Project
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+LOCAL_PATH:= $(call my-dir)
+
+include $(CLEAR_VARS)
+
+LOCAL_SRC_FILES := $(call all-java-files-under, src)
+
+LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
+
+LOCAL_PACKAGE_NAME := CarSetupWizard
+
+LOCAL_CERTIFICATE := platform
+
+LOCAL_MODULE_TAGS := optional
+
+LOCAL_PRIVILEGED_MODULE := true
+
+# For setup wizard common lib
+LOCAL_STATIC_JAVA_LIBRARIES += android-setup-wizard-common
+LOCAL_AAPT_FLAGS += --auto-add-overlay --extra-packages com.google.android.setupwizard.common
+LOCAL_RESOURCE_DIR += vendor/google/apps/SetupWizard/libs/base/res
+
+LOCAL_PROGUARD_ENABLED := disabled
+
+LOCAL_DEX_PREOPT := false
+
+include frameworks/opt/setupwizard/library/common-gingerbread.mk
+include frameworks/base/packages/SettingsLib/common.mk
+
+include $(BUILD_PACKAGE)