aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Cross <ccross@android.com>2020-01-09 15:09:11 -0800
committerColin Cross <ccross@android.com>2020-01-16 13:59:51 -0800
commit9b3cfe574eac7c3fb8901400f0de5bc9597f3d00 (patch)
tree039cfea8cfc1515f4cdef94b09da1387b555dd73
parentd8894ee30094fc503ca16ba3d39f1806ea9899b3 (diff)
downloadtests-9b3cfe574eac7c3fb8901400f0de5bc9597f3d00.tar.gz
Convert TestMediaApp to Android.bpandroid-r-preview-1
See build/soong/README.md for more information. Fixes: 144290484 Test: m TestMediaApp Change-Id: I5db1b352395b50a7820dcef552adf16e09eacd60 Merged-In: I5db1b352395b50a7820dcef552adf16e09eacd60 Exempt-From-Owner-Approval: cherry-pick (cherry picked from commit 613f410a13c76bd0e3bd4b1146ddfdba858b0c5e)
-rw-r--r--TestMediaApp/Android.bp52
-rw-r--r--TestMediaApp/Android.mk52
2 files changed, 52 insertions, 52 deletions
diff --git a/TestMediaApp/Android.bp b/TestMediaApp/Android.bp
new file mode 100644
index 0000000..f2f6d59
--- /dev/null
+++ b/TestMediaApp/Android.bp
@@ -0,0 +1,52 @@
+//
+// Copyright (C) 2019 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+//
+
+// Actual Package:
+
+android_app {
+ name: "TestMediaApp",
+
+ srcs: ["src/**/*.java"],
+
+ resource_dirs: ["res"],
+
+ platform_apis: true,
+
+ certificate: "platform",
+
+ // car_car is ok here because this is meant to simulate a third party media app
+ // Do NOT add dependencies preventing the app from being unbundled (compiled with gradle in Studio).
+ static_libs: [
+ "androidx.car_car",
+ "androidx.appcompat_appcompat",
+ "androidx.preference_preference",
+ "androidx.legacy_legacy-support-v4",
+ ],
+
+ optimize: {
+ enabled: false,
+ },
+
+ dex_preopt: {
+ enabled: false,
+ },
+
+ product_variables: {
+ pdk: {
+ enabled: false,
+ },
+ },
+}
diff --git a/TestMediaApp/Android.mk b/TestMediaApp/Android.mk
deleted file mode 100644
index 67127e0..0000000
--- a/TestMediaApp/Android.mk
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Copyright (C) 2019 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-
-ifneq ($(TARGET_BUILD_PDK), true)
-
-LOCAL_PATH:= $(call my-dir)
-
-# Actual Package:
-
-include $(CLEAR_VARS)
-
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
-
-LOCAL_PACKAGE_NAME := TestMediaApp
-LOCAL_PRIVATE_PLATFORM_APIS := true
-
-LOCAL_CERTIFICATE := platform
-
-LOCAL_MODULE_TAGS := optional
-
-# car_car is ok here because this is meant to simulate a third party media app
-# Do NOT add dependencies preventing the app from being unbundled (compiled with gradle in Studio).
-LOCAL_STATIC_ANDROID_LIBRARIES := \
- androidx.car_car \
- androidx.appcompat_appcompat \
- androidx.preference_preference \
- androidx.legacy_legacy-support-v4
-
-LOCAL_USE_AAPT2 := true
-
-LOCAL_PROGUARD_ENABLED := disabled
-
-LOCAL_DEX_PREOPT := false
-
-include $(BUILD_PACKAGE)
-
-endif