summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-12-13 13:14:07 +0000
committerPaul Duffin <paulduffin@google.com>2017-12-13 14:28:27 +0000
commit0ffa34a887cc56a259dc9904eafcda8f5d452641 (patch)
treec67b9ac6d3a634d2aba5811f0d358ec4b3ad03ed /tests
parent61ab8cfb1537d5346516d1877e300a3be34fc1e2 (diff)
downloadContacts-0ffa34a887cc56a259dc9904eafcda8f5d452641.tar.gz
Add android.test.runner.stubs dependency
In preparation for the removal of the non-junit classes in the android.test.runner library from the android.jar this adds a dependency on android.test.runner.stubs to ensure this code will continue to compile. The following change descriptions were generated automatically and so may be a little repetitive. They are provided to give the reviewer enough information to check the comments match what has actually been changed and check the reasoning behind the changes. * tests/Android.mk Added 'android.test.runner.stubs' to LOCAL_JAVA_LIBRARIES because ContactsTests's will needs them in order to compile once its classes are removed from the current SDK on which it currently depends. Bug: 30188076 Test: make checkbuild Change-Id: Id461d950eb755237676c135275f5d84ad81487b5
Diffstat (limited to 'tests')
-rw-r--r--tests/Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
index 09c97cd77..e26408940 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -23,6 +23,7 @@ LOCAL_STATIC_JAVA_LIBRARIES += \
mockito-target-minus-junit4 \
ub-uiautomator
+LOCAL_JAVA_LIBRARIES := android.test.runner.stubs
LOCAL_AAPT_FLAGS := \
--auto-add-overlay \