summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-12-15 16:17:03 +0000
committerPaul Duffin <paulduffin@google.com>2017-12-15 16:17:03 +0000
commite3f7d775f8b824b2329853e5b5218d05a4181abb (patch)
treeff576f79eea0b0a1f54bc0372f6a99c33edd05dc /tests
parentb11239e2c1a2f4d403595736b298016adc072ac6 (diff)
downloadContacts-e3f7d775f8b824b2329853e5b5218d05a4181abb.tar.gz
Add android.test.mock/stubs dependency
In preparation for the removal of the android.test.mock classes from the android.jar this adds dependencies on android.test.mock/stubs to ensure this code will continue to compile. The following change descriptions were generated automatically and so may be a little repetitive. They are provided to give the reviewer enough information to check the comments match what has actually been changed and check the reasoning behind the changes. * tests/Android.mk Added 'android.test.mock.stubs' to LOCAL_JAVA_LIBRARIES because ContactsTests's will need them in order to compile once its classes are removed from the current SDK on which it currently depends. Bug: 30188076 Test: make dist Change-Id: I3944e6f5049c2c369c5e18c396208dea8c255b83
Diffstat (limited to 'tests')
-rw-r--r--tests/Android.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
index a70af4833..dfea84366 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -23,7 +23,11 @@ LOCAL_STATIC_JAVA_LIBRARIES += \
mockito-target-minus-junit4 \
ub-uiautomator
-LOCAL_JAVA_LIBRARIES := android.test.runner.stubs android.test.base.stubs
+LOCAL_JAVA_LIBRARIES := \
+ android.test.runner.stubs \
+ android.test.base.stubs \
+ android.test.mock.stubs \
+
LOCAL_AAPT_FLAGS := \
--auto-add-overlay \