summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasha Smundak <asmundak@google.com>2019-01-11 19:20:52 -0800
committerandroid-build-merger <android-build-merger@google.com>2019-01-11 19:20:52 -0800
commit4d32d89446a3a9d7f7ec9b85d6ea6261ecc21b0b (patch)
tree1dfc877e1f890080552b08e23dee4bc21eddec7b
parent313ea4c6c14875916df65ba3b76bbcb0acf4a0ea (diff)
parent944a9e262754b33e24552bf8a3d69f100a9cac44 (diff)
downloadDevCamera-4d32d89446a3a9d7f7ec9b85d6ea6261ecc21b0b.tar.gz
Convert Android.mk file to Android.bp
am: 944a9e2627 Change-Id: Ibbb29fb42e518006b3a42deec019d18cb27f2e25
-rw-r--r--Android.bp19
-rw-r--r--Android.mk29
2 files changed, 19 insertions, 29 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..08ce88c
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,19 @@
+// Copyright (C) 2016 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+android_app {
+ name: "DevCamera",
+ sdk_version: "current",
+ min_sdk_version: "21",
+ srcs: ["src/**/*.java"],
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100644
index d3deaac..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright (C) 2016 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-LOCAL_PATH := $(call my-dir)
-
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := optional
-
-LOCAL_SDK_VERSION := current
-LOCAL_MIN_SDK_VERSION := 21
-
-LOCAL_SRC_FILES := \
- $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := DevCamera
-
-include $(BUILD_PACKAGE)