summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasha Smundak <asmundak@google.com>2019-01-11 19:41:59 -0800
committerandroid-build-merger <android-build-merger@google.com>2019-01-11 19:41:59 -0800
commit4788295eedbffb1effd803b4ce866af356fce066 (patch)
tree1dfc877e1f890080552b08e23dee4bc21eddec7b
parentbb9b4775041e89f425fa60e15715cf7a69d8d753 (diff)
parent02f6d1eb11a5c5514e22910573b312ee70f1dafc (diff)
downloadDevCamera-4788295eedbffb1effd803b4ce866af356fce066.tar.gz
Convert Android.mk file to Android.bp am: 944a9e2627 am: 4d32d89446
am: 02f6d1eb11 Change-Id: Ib04ed851a304f970979768cc896d43637a1ca5ef
-rw-r--r--Android.bp19
-rw-r--r--Android.mk29
2 files changed, 19 insertions, 29 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..08ce88c
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,19 @@
+// Copyright (C) 2016 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+android_app {
+ name: "DevCamera",
+ sdk_version: "current",
+ min_sdk_version: "21",
+ srcs: ["src/**/*.java"],
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100644
index d3deaac..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright (C) 2016 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-LOCAL_PATH := $(call my-dir)
-
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := optional
-
-LOCAL_SDK_VERSION := current
-LOCAL_MIN_SDK_VERSION := 21
-
-LOCAL_SRC_FILES := \
- $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := DevCamera
-
-include $(BUILD_PACKAGE)