summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-01-17 15:40:48 +0000
committerPaul Duffin <paulduffin@google.com>2017-01-17 15:40:48 +0000
commit66f4e26ef989745f66432d080f57682a7732b3e1 (patch)
treef59ea9e5ece30a7840aa3d454e842e584bff8f7a /tests
parent09b065b9a794e3e254d40fd4dd2a98f0cd0673e0 (diff)
downloadGallery-66f4e26ef989745f66432d080f57682a7732b3e1.tar.gz
Prepare for removal of legacy-test from default targets
In preparation for removing junit classes from the Android API the legacy-test target will be removed from the TARGET_DEFAULT_JAVA_LIBRARIES. This change adds explicit dependencies on junit and/or legacy-android-test to ensure that modules will compile properly once it is removed. Bug: 30188076 Test: make checkbuild Change-Id: I0b430f48a763543b3b86318ac938fd13ae5caafc
Diffstat (limited to 'tests')
-rw-r--r--tests/Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Android.mk b/tests/Android.mk
index 10f7a81..eef3da7 100644
--- a/tests/Android.mk
+++ b/tests/Android.mk
@@ -6,6 +6,7 @@ LOCAL_MODULE_TAGS := tests
LOCAL_CERTIFICATE := media
LOCAL_JAVA_LIBRARIES := android.test.runner
+LOCAL_STATIC_JAVA_LIBRARIES := junit legacy-android-test
# Include all test java files.
LOCAL_SRC_FILES := $(call all-java-files-under, src)