summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-23 11:51:41 +0000
committerAnton Hansson <hansson@google.com>2018-02-27 20:46:13 +0000
commitdaf01c2701537ef131e9c99f5d8107d02f09d43c (patch)
treea110d25847d006483d6eab90487e1aa28ccc32da
parent1ceaeb18b638f14f50db39e82b217d39ff4ef24c (diff)
downloadLauncher2-daf01c2701537ef131e9c99f5d8107d02f09d43c.tar.gz
packages/apps/Launcher2: Set LOCAL_SDK_VERSION where possible.
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: Id2fb0111c37a6ebc5c3962cc13db9bff03f81a6f
-rw-r--r--tests/stress/Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/stress/Android.mk b/tests/stress/Android.mk
index 30963e50..c1b2069b 100644
--- a/tests/stress/Android.mk
+++ b/tests/stress/Android.mk
@@ -24,6 +24,7 @@ LOCAL_STATIC_JAVA_LIBRARIES := junit
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := LauncherRotationStressTest
+LOCAL_PRIVATE_PLATFORM_APIS := true
LOCAL_CERTIFICATE := shared