summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Duffin <paulduffin@google.com>2017-01-17 14:49:42 +0000
committerPaul Duffin <paulduffin@google.com>2017-01-17 14:49:42 +0000
commit3c39cfc308c7505c5197cc955053c366b5b258a4 (patch)
tree431c29a6458f25bd3a41e26b4085833afbfebfde
parentdb9e56344d2ef16618aa7227058028229d410431 (diff)
downloadLauncher2-3c39cfc308c7505c5197cc955053c366b5b258a4.tar.gz
Prepare for removal of legacy-test from default targets
In preparation for removing junit classes from the Android API the legacy-test target will be removed from the TARGET_DEFAULT_JAVA_LIBRARIES. This change adds explicit dependencies on junit and/or legacy-android-test to ensure that modules will compile properly once it is removed. Bug: 30188076 Test: make checkbuild Change-Id: I5d5bc7a003e660398a8238c0a0a2e1c7085ec02e
-rw-r--r--tests/stress/Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/stress/Android.mk b/tests/stress/Android.mk
index 68289bd3..3c911793 100644
--- a/tests/stress/Android.mk
+++ b/tests/stress/Android.mk
@@ -19,6 +19,7 @@ include $(CLEAR_VARS)
LOCAL_MODULE_TAGS := tests
LOCAL_JAVA_LIBRARIES := android.test.runner
+LOCAL_STATIC_JAVA_LIBRARIES := junit legacy-android-test
LOCAL_SRC_FILES := $(call all-java-files-under, src)