aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandroid-build-team Robot <android-build-team-robot@google.com>2021-05-13 01:09:33 +0000
committerandroid-build-team Robot <android-build-team-robot@google.com>2021-05-13 01:09:33 +0000
commitd5e7fecfb0e5f888c56294540586b087d3812619 (patch)
tree3b9c0bcfc5a8e9a5dc8786e3166ec6028b466dc2
parent565507ea121d66d59ced6a96dd3ad1d8993b6496 (diff)
parent7f113e2a81ed81a3cabeb098fd27a0dcf6e557bb (diff)
downloadMessaging-d5e7fecfb0e5f888c56294540586b087d3812619.tar.gz
Snap for 7357013 from 7f113e2a81ed81a3cabeb098fd27a0dcf6e557bb to sc-releaseandroid-vts-12.0_r9android-vts-12.0_r8android-vts-12.0_r7android-vts-12.0_r6android-vts-12.0_r5android-vts-12.0_r4android-vts-12.0_r3android-vts-12.0_r2android-vts-12.0_r12android-vts-12.0_r11android-vts-12.0_r10android-vts-12.0_r1android-security-12.0.0_r60android-security-12.0.0_r59android-security-12.0.0_r58android-security-12.0.0_r57android-security-12.0.0_r56android-security-12.0.0_r55android-security-12.0.0_r54android-security-12.0.0_r53android-security-12.0.0_r52android-security-12.0.0_r51android-security-12.0.0_r50android-security-12.0.0_r49android-security-12.0.0_r48android-security-12.0.0_r47android-security-12.0.0_r46android-security-12.0.0_r45android-security-12.0.0_r44android-security-12.0.0_r43android-security-12.0.0_r42android-security-12.0.0_r41android-security-12.0.0_r40android-security-12.0.0_r39android-security-12.0.0_r38android-security-12.0.0_r37android-security-12.0.0_r36android-security-12.0.0_r35android-security-12.0.0_r34android-platform-12.0.0_r1android-cts-12.0_r9android-cts-12.0_r8android-cts-12.0_r7android-cts-12.0_r6android-cts-12.0_r5android-cts-12.0_r4android-cts-12.0_r3android-cts-12.0_r2android-cts-12.0_r12android-cts-12.0_r11android-cts-12.0_r10android-cts-12.0_r1android-12.0.0_r9android-12.0.0_r8android-12.0.0_r34android-12.0.0_r33android-12.0.0_r31android-12.0.0_r30android-12.0.0_r3android-12.0.0_r25android-12.0.0_r2android-12.0.0_r11android-12.0.0_r10android-12.0.0_r1android12-tests-releaseandroid12-security-releaseandroid12-s5-releaseandroid12-s4-releaseandroid12-s3-releaseandroid12-s2-releaseandroid12-s1-releaseandroid12-release
Change-Id: I48b3504fb2f5e2d9b50df69b061c06a6bf5d50b4
-rw-r--r--jni/Android.bp40
-rw-r--r--jni/Android.mk39
2 files changed, 40 insertions, 39 deletions
diff --git a/jni/Android.bp b/jni/Android.bp
new file mode 100644
index 0000000..22840ea
--- /dev/null
+++ b/jni/Android.bp
@@ -0,0 +1,40 @@
+// Copyright (C) 2015 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
+cc_library_shared {
+ name: "libgiftranscode",
+ static_libs: ["libgif"],
+ // Link to Android logging (liblog.so) and dynamic linker (libdl.so) libraries
+ shared_libs: [
+ "liblog",
+ "libdl",
+ ],
+ // for including the jni.h file
+ header_libs: ["jni_headers"],
+ include_dirs: ["external/giflib"],
+ srcs: ["GifTranscoder.cpp"],
+ cflags: [
+ "-Wno-unused-parameter",
+ "-Wno-switch",
+ ],
+ sdk_version: "19",
+ // LLVM libc++
+ stl: "c++_static",
+ product_specific: true,
+}
diff --git a/jni/Android.mk b/jni/Android.mk
deleted file mode 100644
index 36edaec..0000000
--- a/jni/Android.mk
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright (C) 2015 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-LOCAL_PATH := $(call my-dir)
-
-include $(CLEAR_VARS)
-
-LOCAL_STATIC_LIBRARIES += libgif
-
-# Link to Android logging (liblog.so) and dynamic linker (libdl.so) libraries
-LOCAL_LDFLAGS := -llog -ldl
-
-LOCAL_C_INCLUDES := \
- external/giflib
-
-LOCAL_MODULE := libgiftranscode
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-LOCAL_SRC_FILES := GifTranscoder.cpp
-
-LOCAL_CFLAGS += -Wall -Werror -Wno-unused-parameter -Wno-switch
-
-LOCAL_SDK_VERSION := 19
-LOCAL_NDK_STL_VARIANT := c++_static # LLVM libc++
-
-LOCAL_PRODUCT_MODULE := true
-
-include $(BUILD_SHARED_LIBRARY)