summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasha Smundak <asmundak@google.com>2019-01-13 14:32:54 -0800
committerandroid-build-merger <android-build-merger@google.com>2019-01-13 14:32:54 -0800
commit4b155f3f12477ca782d86afd10c482953a9e89a1 (patch)
tree9f37287817f976950a818ee47e4ae81ec287fa34
parent08bd3b50af673adc8f9aec5c37fcd40f8feea0fd (diff)
parent069ba8677d3881928fb8e8f4bc425eaba6808b40 (diff)
downloadMusicFX-4b155f3f12477ca782d86afd10c482953a9e89a1.tar.gz
Merge "Convert Android.mk file to Android.bp"
am: 069ba8677d Change-Id: If2d4cd88fa5103fa8da663f5a1159367474e8ec0
-rw-r--r--Android.bp7
-rw-r--r--Android.mk15
2 files changed, 7 insertions, 15 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..c9d7b8c
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,7 @@
+android_app {
+ name: "MusicFX",
+ srcs: ["src/**/*.java"],
+ libs: ["framework"],
+ platform_apis: true,
+ privileged: true,
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100644
index 02e8f04..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,15 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := optional
-
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_JAVA_LIBRARIES := framework
-
-LOCAL_PACKAGE_NAME := MusicFX
-LOCAL_PRIVATE_PLATFORM_APIS := true
-
-LOCAL_PRIVILEGED_MODULE := true
-
-include $(BUILD_PACKAGE)