summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandroid-build-team Robot <android-build-team-robot@google.com>2019-01-13 04:03:15 +0000
committerandroid-build-team Robot <android-build-team-robot@google.com>2019-01-13 04:03:15 +0000
commit83854a5a111ab47c9196aeaf2da6c2db6ca3d734 (patch)
treed1483cd203b3c2e9c0b5484ddf4530706921fcd6
parent394b182666fb043019705b23c1837c9a5ee8da70 (diff)
parente5966493be8f8c29e2e2fc35fcd5d83850ce57ea (diff)
downloadOneTimeInitializer-83854a5a111ab47c9196aeaf2da6c2db6ca3d734.tar.gz
Snap for 5228332 from e5966493be8f8c29e2e2fc35fcd5d83850ce57ea to qt-release
Change-Id: I7144f2b407e4b44dc890a07a4c5d084ea64bd86d
-rw-r--r--Android.bp26
-rw-r--r--Android.mk33
2 files changed, 26 insertions, 33 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..bb17699
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,26 @@
+//
+// Copyright (C) 2012 The Android Open Source Project
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+//
+
+android_app {
+ name: "OneTimeInitializer",
+ srcs: ["src/**/*.java"],
+ static_libs: ["android-common"],
+ sdk_version: "current",
+ privileged: true,
+ optimize: {
+ proguard_flags_files: ["proguard.flags"],
+ },
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100644
index 1956fcd..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,33 +0,0 @@
-#
-# Copyright (C) 2012 The Android Open Source Project
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := optional
-
-LOCAL_SRC_FILES := $(call all-java-files-under,src)
-
-LOCAL_STATIC_JAVA_LIBRARIES += android-common
-
-LOCAL_PACKAGE_NAME := OneTimeInitializer
-LOCAL_SDK_VERSION := current
-
-LOCAL_PRIVILEGED_MODULE := true
-
-LOCAL_PROGUARD_FLAG_FILES := proguard.flags
-
-include $(BUILD_PACKAGE)