summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 16:12:25 +0000
committerAnton Hansson <hansson@google.com>2018-02-22 16:12:25 +0000
commit3e5bd08e3fe8de69c4efc70f84fc9363f62f4801 (patch)
treeb86cc5ab72638f2ae125729ec63045ee15f07c38
parentb070b0f331ae4bd9adb13702a1072b9ef5927b26 (diff)
downloadSafetyRegulatoryInfo-3e5bd08e3fe8de69c4efc70f84fc9363f62f4801.tar.gz
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: Ia9fae463164dc2b25be5076c2a2a916d76de694a
-rw-r--r--Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 96eb039..fd9aaa8 100644
--- a/Android.mk
+++ b/Android.mk
@@ -8,5 +8,6 @@ LOCAL_SRC_FILES := $(call all-subdir-java-files)
LOCAL_PROGUARD_ENABLED := disabled
LOCAL_PACKAGE_NAME := SafetyRegulatoryInfo
+LOCAL_SDK_VERSION := current
include $(BUILD_PACKAGE)