summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuntao Xu <yuntaoxu@google.com>2021-05-04 16:42:13 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2021-05-04 16:42:13 +0000
commit77c3522420b8647317cfa8628cdf2c084819ecf0 (patch)
treebd514b1ad50003974d14db8981ac2603830559dc
parent352b31d43becfd0e5a0a0e1dc197c68bf46b12d0 (diff)
parentb41a26429f40b2da75da6fcb0c1764880c51c08d (diff)
downloadSampleLocationAttribution-77c3522420b8647317cfa8628cdf2c084819ecf0.tar.gz
Convert Android.mk to Android.bp am: db999d6341 am: b41a26429f
Original change: https://android-review.googlesource.com/c/platform/packages/apps/SampleLocationAttribution/+/1689364 Change-Id: Iea3b6f5fbe33cc14ba13aa1a943ec19edd8b3067
-rw-r--r--Android.bp17
-rw-r--r--Android.mk26
2 files changed, 17 insertions, 26 deletions
diff --git a/Android.bp b/Android.bp
new file mode 100644
index 0000000..c5a4f18
--- /dev/null
+++ b/Android.bp
@@ -0,0 +1,17 @@
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
+android_app {
+ name: "SampleLocationAttribution",
+ resource_dirs: ["res"],
+ static_libs: [
+ "androidx.core_core",
+ "androidx.appcompat_appcompat",
+ ],
+ // Build all java files in the src subdirectory
+ srcs: ["src/**/*.java"],
+ sdk_version: "current",
+ product_specific: true,
+}
diff --git a/Android.mk b/Android.mk
deleted file mode 100644
index dbf609b..0000000
--- a/Android.mk
+++ /dev/null
@@ -1,26 +0,0 @@
-LOCAL_PATH := $(call my-dir)
-
-include $(CLEAR_VARS)
-
-LOCAL_USE_AAPT2 := true
-
-LOCAL_RESOURCE_DIR := $(LOCAL_PATH)/res
-
-LOCAL_STATIC_ANDROID_LIBRARIES := \
- androidx.core_core \
- androidx.appcompat_appcompat
-
-# Build all java files in the src subdirectory
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_SDK_VERSION := current
-
-LOCAL_PRODUCT_MODULE := true
-
-# Name of the APK to build
-LOCAL_PACKAGE_NAME := SampleLocationAttribution
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-
-# Tell it to build an APK
-include $(BUILD_PACKAGE)