summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 16:12:26 +0000
committerAnton Hansson <hansson@google.com>2018-02-22 16:12:26 +0000
commit9e7197432f353e83e9b650ddda75848e2a7e9fc1 (patch)
tree6b41fac8e81ee90f4455104011d876f57bb234d8
parente6556339e7843be665238dd9b53a22a37d4eddb7 (diff)
downloadSecureElement-9e7197432f353e83e9b650ddda75848e2a7e9fc1.tar.gz
packages/apps/SecureElement: Set LOCAL_SDK_VERSION where possible.
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: I1be7299c3ae0f52340a45b8ff9b5ac8b8ae76285
-rwxr-xr-xAndroid.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index 55ecd5b..ed2950e 100755
--- a/Android.mk
+++ b/Android.mk
@@ -4,6 +4,7 @@ include $(CLEAR_VARS)
LOCAL_SRC_FILES := $(call all-java-files-under, src)
LOCAL_PACKAGE_NAME := SecureElement
+LOCAL_PRIVATE_PLATFORM_APIS := true
LOCAL_CERTIFICATE := platform
LOCAL_MODULE_TAGS := optional