summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 16:12:31 +0000
committerAnton Hansson <hansson@google.com>2018-02-22 16:12:31 +0000
commit84b20362de80b94c08cf193414ae5ce8c9b65901 (patch)
treefb59bb4cf3e8099125ef3a7bd9f6d5b77e30e064
parentf47fff0421153f4c20d155df8d0864a7036bdb06 (diff)
downloadSpareParts-84b20362de80b94c08cf193414ae5ce8c9b65901.tar.gz
packages/apps/SpareParts: Set LOCAL_SDK_VERSION where possible.
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: I4bfe8d70d000e067fdb46da8fe123233d7ccd9af
-rw-r--r--Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index a6ab6e9..790d42c 100644
--- a/Android.mk
+++ b/Android.mk
@@ -6,5 +6,6 @@ LOCAL_MODULE_TAGS := optional
LOCAL_SRC_FILES := $(call all-subdir-java-files)
LOCAL_PACKAGE_NAME := SpareParts
+LOCAL_PRIVATE_PLATFORM_APIS := true
include $(BUILD_PACKAGE)