summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Hansson <hansson@google.com>2018-02-22 16:12:32 +0000
committerAnton Hansson <hansson@google.com>2018-02-22 16:12:32 +0000
commit63c501d530117b935186bf008404d24c5552b7ef (patch)
treeab3dd57cc6e948f9fecf39493a745713caac0d25
parent5a2d65c45e37e71bb26a7a78c5b6202077704e8a (diff)
downloadStk-63c501d530117b935186bf008404d24c5552b7ef.tar.gz
packages/apps/Stk: Set LOCAL_SDK_VERSION where possible.
This change sets LOCAL_SDK_VERSION for all packages where this is possible without breaking the build, and LOCAL_PRIVATE_PLATFORM_APIS := true otherwise. Setting one of these two will be made required soon, and this is a change in preparation for that. Not setting LOCAL_SDK_VERSION makes the app implicitly depend on the bootclasspath, which is often not required. This change effectively makes depending on private apis opt-in rather than opt-out. Test: make relevant packages Bug: 73535841 Change-Id: If3c75e38344454d8729be4a2cd065f547f826b4a
-rw-r--r--Android.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Android.mk b/Android.mk
index a9e2d1d..135fcf9 100644
--- a/Android.mk
+++ b/Android.mk
@@ -10,6 +10,7 @@ LOCAL_STATIC_JAVA_LIBRARIES := android-support-v4
LOCAL_SRC_FILES := $(call all-subdir-java-files)
LOCAL_PACKAGE_NAME := Stk
+LOCAL_PRIVATE_PLATFORM_APIS := true
LOCAL_CERTIFICATE := platform
include $(BUILD_PACKAGE)