aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJi-Hwan Lee <jihwan@google.com>2014-08-04 23:33:29 +0900
committerJi-Hwan Lee <jihwan@google.com>2014-08-05 07:11:21 +0000
commit951df7fef03dfa9e60f4f44dffe095e7a02019e5 (patch)
tree50ed98a3487eb4bec4031cedcc4ab08e9797fb94
parentbd61574966d9bda08f8f82bfee24155fa43a82e2 (diff)
downloadTV-951df7fef03dfa9e60f4f44dffe095e7a02019e5.tar.gz
Add SampleTvInput and FakeHardwareTvInput to build server result
Bug: 16779633 Change-Id: I75c5cd19b5007cf8e4f4430262e34d97fddffa50
-rw-r--r--hwsample/Android.mk6
-rw-r--r--sample/Android.mk6
2 files changed, 12 insertions, 0 deletions
diff --git a/hwsample/Android.mk b/hwsample/Android.mk
index ea779e8c..818b7276 100644
--- a/hwsample/Android.mk
+++ b/hwsample/Android.mk
@@ -26,3 +26,9 @@ LOCAL_PRIVILEGED_MODULE := true
LOCAL_MODULE_TAGS := optional
include $(BUILD_PACKAGE)
+
+ifeq ($(PRODUCT_IS_ATV),true)
+ ifneq ($(PRODUCT_IS_ATV_SDK),true)
+ $(call dist-for-goals,dist_files,$(LOCAL_BUILT_MODULE):FakeHardwareTvInput.apk)
+ endif
+endif
diff --git a/sample/Android.mk b/sample/Android.mk
index b06c2ec1..03f4a51d 100644
--- a/sample/Android.mk
+++ b/sample/Android.mk
@@ -8,3 +8,9 @@ LOCAL_MODULE_TAGS := optional
LOCAL_PROGUARD_ENABLED := disabled
include $(BUILD_PACKAGE)
+
+ifeq ($(PRODUCT_IS_ATV),true)
+ ifneq ($(PRODUCT_IS_ATV_SDK),true)
+ $(call dist-for-goals,dist_files,$(LOCAL_BUILT_MODULE):SampleTvInput.apk)
+ endif
+endif