aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYoungsang Cho <youngsang@google.com>2016-03-09 11:50:06 -0800
committerYoungsang Cho <youngsang@google.com>2016-03-09 11:50:06 -0800
commitef6dd31eb29d3a65e1cc280b79170e1e7f72b09a (patch)
tree0222d481ca554acad685016e8a1aeb0ea79ea6a1
parent6991bb6fe77d873dfce9a2ebea244d5b55c548fc (diff)
downloadTV-ef6dd31eb29d3a65e1cc280b79170e1e7f72b09a.tar.gz
Quick fix a build breakage in read-only file system
Bug: 27568978 Change-Id: I64071d6b4ad0cdc610b3f8c8c68a57165092a44b
-rw-r--r--common/Android.mk5
-rw-r--r--common/src/com/android/tv/common/BuildConfig.java10
2 files changed, 10 insertions, 5 deletions
diff --git a/common/Android.mk b/common/Android.mk
index 878cbb8b..96913a1b 100644
--- a/common/Android.mk
+++ b/common/Android.mk
@@ -1,11 +1,6 @@
LOCAL_PATH:= $(call my-dir)
include $(CLEAR_VARS)
-LOCAL_BUILDCONFIG_CLASS := src/com/android/tv/common/BuildConfig.java
-BC_OUT_DIR := $(LOCAL_PATH)
-BC_APPLICATION_ID := "com.android.tv.common"
-include $(LOCAL_PATH)/buildconfig.mk
-
# Include all test java files.
LOCAL_SRC_FILES := $(call all-java-files-under, src) \
$(LOCAL_BUILDCONFIG_CLASS)
diff --git a/common/src/com/android/tv/common/BuildConfig.java b/common/src/com/android/tv/common/BuildConfig.java
new file mode 100644
index 00000000..635903c3
--- /dev/null
+++ b/common/src/com/android/tv/common/BuildConfig.java
@@ -0,0 +1,10 @@
+/**
+ * TODO: It's manually generated file to fix build breakage.
+ * It should be automatically generated.
+ */
+package com.android.tv.common;
+public final class BuildConfig {
+ public static final boolean DEBUG = false;
+ public static final boolean ENG = false;
+ private BuildConfig() {}
+}