aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuntao Xu <yuntaoxu@google.com>2021-05-04 23:06:24 +0000
committerGerrit Code Review <noreply-gerritcodereview@google.com>2021-05-04 23:06:24 +0000
commit05f052f3d7b9d97c1bf70933e547f7c03ae70aa4 (patch)
tree0b6a890691545518bc83b40f5330992b5d7ba234
parent928bbba890784eb97a4fca43c89245724f4773be (diff)
parentaf1b673c6e8708b72f911b3e7a52afbd9cf61743 (diff)
downloadTV-05f052f3d7b9d97c1bf70933e547f7c03ae70aa4.tar.gz
Merge "Convert func/Android.mk to Android.bp"
-rw-r--r--tests/func/Android.bp21
-rw-r--r--tests/func/Android.mk26
2 files changed, 21 insertions, 26 deletions
diff --git a/tests/func/Android.bp b/tests/func/Android.bp
new file mode 100644
index 00000000..d4085394
--- /dev/null
+++ b/tests/func/Android.bp
@@ -0,0 +1,21 @@
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
+android_test {
+ name: "TVFuncTests",
+ // Include all test java files.
+ srcs: ["src/**/*.java"],
+ static_libs: [
+ "androidx.test.runner",
+ "tv-test-common",
+ "ub-uiautomator",
+ ],
+ libs: ["android.test.base.stubs"],
+ instrumentation_for: "LiveTv",
+ sdk_version: "system_current",
+ optimize: {
+ enabled: false,
+ },
+}
diff --git a/tests/func/Android.mk b/tests/func/Android.mk
deleted file mode 100644
index 60290c2d..00000000
--- a/tests/func/Android.mk
+++ /dev/null
@@ -1,26 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_MODULE_TAGS := tests
-
-
-# Include all test java files.
-LOCAL_SRC_FILES := $(call all-java-files-under, src)
-
-LOCAL_PACKAGE_NAME := TVFuncTests
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-
-LOCAL_STATIC_JAVA_LIBRARIES := \
- androidx.test.runner \
- tv-test-common \
- ub-uiautomator \
-
-LOCAL_JAVA_LIBRARIES := android.test.base.stubs
-
-LOCAL_INSTRUMENTATION_FOR := LiveTv
-
-LOCAL_SDK_VERSION := system_current
-
-LOCAL_PROGUARD_ENABLED := disabled
-include $(BUILD_PACKAGE)