aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuntao Xu <yuntaoxu@google.com>2021-05-10 20:23:51 +0000
committerGerrit Code Review <noreply-gerritcodereview@google.com>2021-05-10 20:23:51 +0000
commit1ea232f323eafdfa9dd48c1cf513aadb9d509e49 (patch)
tree367614cf8c01942a76e2f466cd6a3fdbb89011b8
parentcf6de91aed953e377dc9b782e5894cdde119a541 (diff)
parent2e1c4d097c0816e0339df222fbf199af479cbf02 (diff)
downloadTV-1ea232f323eafdfa9dd48c1cf513aadb9d509e49.tar.gz
Merge "Convert Android.mk to Android.bp"android-s-beta-2android-s-beta-1
-rw-r--r--partner_support/sample_customization/Android.bp16
-rw-r--r--partner_support/sample_customization/Android.mk20
2 files changed, 16 insertions, 20 deletions
diff --git a/partner_support/sample_customization/Android.bp b/partner_support/sample_customization/Android.bp
new file mode 100644
index 00000000..f428f402
--- /dev/null
+++ b/partner_support/sample_customization/Android.bp
@@ -0,0 +1,16 @@
+package {
+ // See: http://go/android-license-faq
+ default_applicable_licenses: ["Android-Apache-2.0"],
+}
+
+android_app {
+ name: "PartnerSupportSampleCustomization",
+ optimize: {
+ enabled: false,
+ },
+ // Overlay view related functionality requires system APIs.
+ sdk_version: "system_current",
+ min_sdk_version: "23",
+ // Required for customization
+ privileged: true,
+}
diff --git a/partner_support/sample_customization/Android.mk b/partner_support/sample_customization/Android.mk
deleted file mode 100644
index e74a9268..00000000
--- a/partner_support/sample_customization/Android.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-LOCAL_PATH:= $(call my-dir)
-include $(CLEAR_VARS)
-
-LOCAL_PACKAGE_NAME := PartnerSupportSampleCustomization
-LOCAL_LICENSE_KINDS := SPDX-license-identifier-Apache-2.0
-LOCAL_LICENSE_CONDITIONS := notice
-LOCAL_MODULE_TAGS := optional
-
-LOCAL_PROGUARD_ENABLED := disabled
-# Overlay view related functionality requires system APIs.
-LOCAL_SDK_VERSION := system_current
-LOCAL_MIN_SDK_VERSION := 23 # M
-
-# Required for customization
-LOCAL_PRIVILEGED_MODULE := true
-
-LOCAL_RESOURCE_DIR := \
- $(LOCAL_PATH)/res
-
-include $(BUILD_PACKAGE)